Question

can't open my account through the login button after putting in my username and password?

  • 17 December 2019
  • 6 replies
  • 87 views

Why doesn’t the login button work to let me into my account after I have put in my correct username and password?


6 replies

Userlevel 5
Badge +6

Hi there @wallisparfitt 

Is this through the iD Mobile App you’re having these problems?  Or is this through our website?
If it’s through the website, could you try using a different browser for us -or- deleting the cookies/ cache in your current browser before trying again?

 

If this is happening in the app, then it might be worth deleting the app and re-installing it.

 

Failing all of the above, try resetting your password.  Keep us posted with how you get on.

Can’t logon using username and password

Userlevel 6
Badge +6

Hello @Margaret1947,

 

How are you accessing this?

We’ve had reports of issues with Internet Explorer/Edge browsers so switching to a different browser or the app should fix this.

 

Mohammed

Tried via Chrome and Safari. How come I can login to the Community but not account? Same details...

Userlevel 5
Badge +6

What error message are you receiving when trying @Margaret1947?

 

Have you tried resetting your password and trying again?  All passwords would be case-sensitive and require a capital letter and a number.

Userlevel 6
Badge +6

Tried via Chrome and Safari. How come I can login to the Community but not account? Same details...

 

Hello @Margaret1947  the Community is a separate part of the website with entirely different accounts and on a different platform altogether.

 

Reply