Question

Ports and protocols needed for WiFi calling?

  • 13 January 2020
  • 6 replies
  • 106 views

My workplace has very weak mobile signal strength (due mainly to its location). I am able to activate and use WiFi calling at home on my Samsung S8, so I know it works, but not in the office on the company network. I spoke to an IT guy who suspected that the necessary ports and/or protocols to allow WiFi calling may not be open.

Does anyone know what the specific requirements are (IP address, protocol, port numbers), so that I can see if they can be enabled?

 

Cheers,

             James


6 replies

Right….so that was a big mistake. I thought I would Live chat ID Mobile just to see if they could give me any direct information. The very polite agent then gave me the number for a subscription-only remote tech company…...:rage:

Userlevel 1

Hi @JamesB197 A few ideas for you. A quick google suggests the ports are fairly standard so if your IT guy is fairly accommodating I’d say a good first step would be trying ports UDP 500 and UDP 4500.

If they need to bind those to a destination IP, then you might need to try and work that out yourself. You could get a packet capture app from the play store, then take a packet capture when at home where it works. (start capture, make a call, stop capture) With a a bit of luck and filtering I reckon you should be able to work out the ports and IP.

 

I would offer to do this for you, but I’m having my own trouble trying to get this feature working which is where I’d be really grateful for some help.​​​​​​ please.

  1. Did you get your S8 through iD mobile?
  2. If not was it from another network, or just unlocked/ stock?
  3. Let me know your firmware by typing *#1234# into the dialer

  4. Go to the play store and get the app:  Phone INFO *SAM* - then scroll to the ‘CSC Code’ tab and let me know the Active CSC code. 

Thanks Adam

Hi @Adam_uk  after posting I did a bit more research and came up with the same generic UDP ports. I’m waiting to hear back from IT but the Firewall may be buttoned up so tight that the IP address(es) for WiFi calling may also be blocked. In answer to your questions, it took a little bravery to get this working:

  1. Nope
  2. Handset was purchased unlocked through Carphone Warehouse, on contract to Vodafone. I flashed the Firmware to Vodafone UK in order to get WiFi calling working with that provider. After moving to iD mobile (SIM only) I tracked down the equivalent fileset using sammobile for the ‘Three’ network and flashed again. WiFi calling now works everywhere except the location I really need it!
  3. AP: G950FXXU6DSK9, CP: G950FXXU6DSK5, CSC: G950FH3G6DSK9
  4. Active CSC is H3G

Regards,

             James

Userlevel 1

Hi @JamesB197 really appreciate your reply, and sorry to hijack your post somewhat. Similar situation, my S7 was on Vodafone, I flashed stock firmware with the BTU CSC, but didn’t get wifi calling working yet.

I’m now thinking either BTU is not correct for iD for wifi calling,  or there is a problem with the particular CSC I’m using.

 

You’ve clearly done better than me and got it working. Using H3G may well be the key!! If the bootloader versions match, then it’s possible to flash just the CSC (which I’m going to try) The HOME CSC also doesn’t wipe your data, but I may have to flash all the ‘THREE’ firmware files to get it working. Thanks for your help!

Hi @Adam_uk. I’m still searching for my own solution, as the IT department copped-out with the excuse that the wireless LAN definitely is configured to allow voice calls over Skype for Business. Marvellous.

The ‘bravery’ bit I referred to was in relation to the flash - I couldn’t get Wifi Calling to work using HOME CSC; it needed a total wipe in favour of H3G and then a blue age reloading/configuring all my apps and passwords.

 

Good Luck,

                     James

Userlevel 1

Hi @JamesB197 Thanks for your help. I also tried the HOME CSC which soft bricked my phone lol. I really didn’t want to go through reloading/configuring for a 2nd time. Anyway the the non HOME variant flashed fine. So like you I got wifi calling working with the H3G CSC.

I did only flash the CSC, so I’ll hopefully still get the quarterly OTA updates.

Hope you find a solution for your problem.

 

Reply