Question

Reading Bill - PDF


Userlevel 1
Just tried on the app to read last months bill details for the first time (never read a bill before) and it says "no application available to perform this operation". My android phone reads other PDF files but I downloaded the adobe app anyway but it still won't open the file. Any ideas please.

14 replies

Userlevel 8
Badge +6
If your phone runs on Android Nougat or newer use your file manager to go to your "Downloads" folder (app called Files) and then tap and hold on the file that you want to open, then tap on 3 dots in the right top corner and tap "Open with" you should be able to choose your Adobe app from there.
Userlevel 6
Badge +7
@Ian1951

You will be better just installing the google chrome browser it has a built in pdf viewer, no need to mess about with file managers or adobe addon crapware.

Head over to the app store you can get it there and its free

Trouble with the adobe pdf viewer its outdated and can lead to virus infections.
the chrome browser now provides an even better experience in terms of both performance and security.
Userlevel 1
Hi - thanks for the advice - I use Chrome as the default browser - but didn’t realise it had a built in pdf viewer which is why I downloaded adobe. I have now uninstalled adobe - checked chrome is my default browser and I still can’t open the ID bills in pdf format - as per my previous screenshot.
Userlevel 6
Badge +7
Hi
Thats easy to fix
  1. Open Chrome.
  2. At the top-right, click More Settings.
  3. At the bottom, click Advanced.
  4. Under 'Privacy and security', click Content settings.
  5. Near the bottom, click PDF documents.
  6. Turn off Download PDF files instead of automatically opening them in Chrome.
Userlevel 1
Thanks looked at that but that appears to be for a computer not an android phone using the ID App.

I have just concluded it doesn't work as it works fine on my wife's iPhone so it is an APP/Android problem.

Thank you
Userlevel 6
Badge +7
Well yeah problem lies with the ID app
That will just download it to the mobile
try to follow Hikari's post but use chrome to open the pdf not adobe
Userlevel 1
I've deleted / uninstalled adobe so back to original position and it won't open

I have not restarted the phone since I started to try and resolve this problem so will try that now and if it doesn't work I am finished with it but if it does I will post on here!

Thanks for trying to help.
Userlevel 6
Badge +7
Okay seems I am getting crossed wires

Ideally you should be using the chrome browser to view the website and not the ID app.
Using chrome should open the pdf right away without the need to go looking for it.

The ID app seems to be misconfigured on your android device.
Try reseting the ID app cache and data from android app manger.
next time you use the ID app when you download a pdf an android message will pop up
asking you to perform an action, select the action to always and to open in chrome.
Userlevel 5
Badge +6
Another important thing @Ian1951 would be to ensure both your version of Android and your iD Mobile app are up to date with the latest versions too.

If problems are still persisting, it might be worth deleting the iD Mobile app entirely off your phone and then re-installing. Keep in mind some of the advice you've had above too in case you had potentially given your phone some sort of wrongful instruction on how it should be handling those files.

We've not had any surge of contact like this through our office recently so the problem does seem to be exclusive to your phone, though we'll be happy to continue to troubleshoot this with you until we've got to the root here.

Kevin
Userlevel 1
Kevin - thanks for your input but I do now think you have a problem that you should investigate.

I am fairly PC / IT literate - built my own website 10 years ago - done a little bit of programming.

I uninstalled the ID App - reinstalled and if you look at the screen shots from the bottom up - you will see some alerts that I followed and acted accordingly.

I keep my apps and operating system updated so I am at a loss to understand why Chrome will not open the PDF files ad suggested.

I personally think the problem lies in the first screenshot - if you agree - suggestions to resolve that issue would be appreciated.

Many thanks - Ian


Userlevel 8
Badge +6
I just got an idea. Maybe try installing this app from Here and see if that helps.
Userlevel 1
Hi - thanks for the suggestion - downloaded it but it didn't work - so logged in through website as opposed to the app and everything worked fine - so although ID are not deluged by complaints about this - if I were them - I would look at their app!

I don't care anymore - wasted too much time trying to resolve this so I am signing out.
Userlevel 6
Badge +6
Hi @Ian1951,

Based upon those screenshots, it seems as though the permissions may not have been set when you first installed the app. Have you made sure that when opening the app for the first time, all permissions it asks for are accepted? You will have to uninstall the app and then reinstall it to make it easy to do this.

I understand if you would like to restrict some permissions, but this would cause an app to not function fully.

Ryan
Userlevel 1
Thanks for the input - but the screenshots show the only permissions asked for and I answered them / took the suggested actions in each case. I then did a clean uninstall / reinstall and answered the permissions again but to no avail.

From now on I will just use the website to access bills - so no big deal.

Reply