Wifi Calling Not Working | Join the discussion, ask questions, share advice.
Solved

Wifi Calling Not Working

  • 17 October 2019
  • 30 replies
  • 6590 views

I have an iPhone SE with iOS 13.1.3. WiFi Calling has stopped working. I have tried all the suggestions ie turning WiFi Calling off and on, resetting the network, rebooting the phone. All to no avail. I know it’s not an issue related to our WiFi/internet service as my wife’s iPhone 5s on a BT contract can make WiFi calls perfectly well. Any suggestions please?

icon

Best answer by Phil 18 October 2019, 14:48

View original

30 replies

I have the same problem with WiFi Calling with my Samsung Galaxy A40 (Android 10) bought a year ago from Carphone Warehouse.  I was having problems with both WiFi Calling and poor network signal when I was with O2.  Sometimes it connected via WiFi, but mostly it didn’t, so although I have great full fibre broadband the phone hardly ever used it.  O2 told me last week that the problem was because I didn’t buy the handset from them.  I called at my local Carphone Warehouse and they recommended moving to iD.  I checked online first and my handset was ‘compatible’ so I went for it.  I’ve just transferred today, but still have the same problem.  Even though I’ve selected WiFi calling On, it’s just On or Off - I can’t go further and select WiFi preferred.  The WiFi calling icon doesn’t show on the phone and still I’m stuck with the phone ignoring my great WiFi and connecting instead via the mobile network (which is a bit hit and miss, although slightly better than O2).  I’ve just followed JohnR’s recommendation of airplane mode and then turning WiFi back on.  This does work!! - but it’s a bit clunky - and as JohnR says - you then have to remember to cancel the airplane mode if you leave the house. Surely if I bought the phone from CW and iD is their own network provider I should be able to use WiFi Calling on a phone iD list as compatible?! 

Userlevel 7
Badge +8

Hi @Toria,

 

You should be able to use it yes. How old is the handset you have now?

 

I’m glad you’ve found a fix, and although it’s a little clunky, it’s best to stick with it if it works. 

 

Will

Hi @Toria,

 

You should be able to use it yes. How old is the handset you have now?

 

I’m glad you’ve found a fix, and although it’s a little clunky, it’s best to stick with it if it works. 

 

Will

 

Hi Will - thank you for your reply.

My Samsung Galaxy A40 is just over 1 year old.  I bought it from Carphone Warehouse in September 2019. I fully updated the software a week ago, but it made no difference.  

It’s not that the WiFi doesn’t work at all, as it works fine when I turn the phone to airplane mode, but I don’t see why I should have to do this.  There seems to be no way to select WiFi preferred - it will only use WiFi when I completely disconnect the phone from the network. 

You say that I should be able to use it.  Could you clarify - do I have a handset problem or a network problem?

Userlevel 8
Badge +9

Hi Will - thank you for your reply.

My Samsung Galaxy A40 is just over 1 year old.  I bought it from Carphone Warehouse in September 2019. I fully updated the software a week ago, but it made no difference.  

It’s not that the WiFi doesn’t work at all, as it works fine when I turn the phone to airplane mode, but I don’t see why I should have to do this.  There seems to be no way to select WiFi preferred - it will only use WiFi when I completely disconnect the phone from the network. 

You say that I should be able to use it.  Could you clarify - do I have a handset problem or a network problem?

 

Hello @Toria,

Just reading this, when you talk about WiFi preferred are you talking about using WiFi for internet browsing or WiFi Calling.

WiFi Calling kicks in automatically, but only when the service required for the call is very poor. I have the same situation in my house.

It’ll come on now and then, but not all the time.

 

It does work though, because as you said, during Airplane mode, it’ll jump to WiFi Calling.

If you’re referring to WiFi preferred for internet usage, by default phones should always prefer WiFi signal but connect to Mobile Data (if turned on) when WiFi drops out. You can just turn off Mobile Data to prevent any connection this way.

 

Mohammed

Reply


Why iD Mobile?