Solved

Emergency calls only being displayed


My phone has been displaying emergency calls only for the past four days. The signal eventually returns around 15:00. What is going on? It’s not acceptable for this to continue?

Can anyone assist with this?

icon

Best answer by Will 22 July 2020, 13:06

If the SIM is working fine in other handsets, it sounds like a phone issue. If it’s still under warranty, I’d recommend getting in touch with the supplier (in this case, Argos).

 

Will

View original

14 replies

For additional clarity:

.Phone has been turned off and switched back on

. Factory settings have been restored

. Sim works on another phone

 

Phone still only shows emergency calls.

Userlevel 4
Badge +2

Hi @Dreamer1701 

Welcome to iD Community.

Can you please confirm which device your using?

Thanks, 

Pearl

Thanks for the welcome and forgive the frustration, it’s been a week!

 

The phone is a Nokia 5.

Userlevel 3
Badge +5

Hi @Dreamer1701 

I have sent you a private message with some more information. 

Please also try the SIM in another handset if possible.

 

Regards.

Aklima

I am having the same issue could you help me? @AklimaRahman or @Pearl_c6 

@iD Support 

Userlevel 6
Badge +8

Hi there @Senan.cunningham 

Could you give us a little more details as to your situation?

Does the phone work away from the home ok?  Or is it not received connection regardless of where you are?  Have you restarted the phone recently just to see if that makes any change?

The phone does not work away from home! It does not work at all. I have restarted and reset to factory settings.

Thanks for the help @Kevin  

Userlevel 6
Badge +8

What phone are you using with the iD SIM @Senan.cunningham?

Are you able to take the iD Mobile SIM out and see if it works at all in any other phone?

Could we get your home postcode just to ensure things are fine there?

Thanks

The phone is an Honor 8A 

 the sim does work in another phone

postcode - DL7 8JA

 

@Kevin 

Userlevel 5
Badge +7

Hi @Senan.cunningham , it sounds like a fault with the handset if that’s the case. Where did you get it from? Was it used with another network previously? It may just be that the SIM is loose inside.

 

Will

Hi @Will

 

I bought the device from Argos. 

 

It was never used with another network as it is new. I have checked the sim loads and it is definitely not loose

 

Thanks for the help 

Userlevel 5
Badge +7

If the SIM is working fine in other handsets, it sounds like a phone issue. If it’s still under warranty, I’d recommend getting in touch with the supplier (in this case, Argos).

 

Will

I have contacted Honor and they are fixing it (hopefully)

 

Thanks for the help @Will 

Userlevel 5
Badge +7

No worries, glad we could help you get to the bottom of it @Senan.cunningham.

 

Will

Reply