My phone says 'not registered on network' and I can't make calls. Can anyone help?

  • 19 September 2019
  • 6 replies

I have been using my phone without any problems until yesterday afternoon when I was unable to make calls and my phone said 'not registered on network'. It seemed to sort itself out in the evening but today it's doing the same. I can't even phone ID. As the online chat option is busy, can anyone here help?

6 replies

Userlevel 7
Badge +9
Hello Ellie, have you tried powering down your phone and removing/re-inserting the SIM then powering this backup?

This can often fix many of the simple network problems. If this hasn't worked by now or still doesn't work, please can you confirm your full postcode for me and I'll check the coverage in your area.

Hi Mohammed. I have just tried taking the SIM out and putting it back in and the same message still shows. People can't phone me either. My son's phone, also on ID, has the same issue. I have got a good signal and the coverage checker says we have good coverage. I'm BS3 1PF.
This is becoming quite urgent now - is there anything else I can try?
Userlevel 7
Badge +9
Hello @EllieFreeman,

Apologies for the delayed response.

For urgent issues, it's always best to contact our Customer Services as this channel isn't a Live Chat service so replies may be delayed.

I've checked the coverage for this postcode and can see that there is currently some unplanned outage that began on the 18/09/19 which would explain the issues you are facing. This outage is still ongoing and is currently being investigated.

I'm not sure why this isn't updated to show on the Coverage Checker on our website.

Apologies for any inconvenience this is causing. I don't yet have a time-frame for a fix.

Userlevel 4
Have you tried renetering your sim into your slim slot.
Make sure you phone is updated if not do this re-eneter sim and power off your phone (holding off button) and restart. If this does not work I advise you to go to carphone wharehouse
Userlevel 4
This happens to me once on my s9 plus but I relived I had not updated my phone, after that it was good to go