Question

no service since joining iD

  • 21 March 2019
  • 2 replies
  • 165 views

I've just switched to ID, my number has been ported, and I can wifi call, but if I'm not wifi connected it says no service and I can't make calls? Any advice

2 replies

Userlevel 6
Badge +1
Hi @loopylou

Have you tried restarting your phone? Sounds obvious but you'd be supprised how many times this has solved the issue.

Also you could try manually disconnecting from the iD network and re-connecting.

If these haven't solved your issue have a look on the coverage checker on the iD website, just pop your postcode in tonsee if there's any service issues in your area.

Just a quick note, it can take up to 2 business days to transfer but i'm assuming you're past that already.

Best Regards
Adam
Userlevel 7
Badge +9
Hi @loopylou

Have you tried restarting your phone? Sounds obvious but you'd be supprised how many times this has solved the issue.

Also you could try manually disconnecting from the iD network and re-connecting.

If these haven't solved your issue have a look on the coverage checker on the iD website, just pop your postcode in tonsee if there's any service issues in your area.

Just a quick note, it can take up to 2 business days to transfer but i'm assuming you're past that already.

Best Regards
Adam



Hey @loopylou,

Try the things that @Adzdalton has advised as these are the most common fixes for coverage issues.

If you have a look at our Coverage Checker you'll be able to determine if there are any coverage issues, it'll show here as this could explain why you're having problems.

Do you also have the issues when you're away from home?

Mohammed

Reply