Question

Others unable to call me

  • 30 June 2020
  • 3 replies
  • 59 views

I have been with iD Mobile around a year and ported my number over from Smarty (though it is originally a Vodafone number from around 1999). Everything has worked fine until now.

 

I am able to make calls fine, but others are unable to call me from the public network, receiving the message "the number you have called is not recognised." I have tried this from both my landline and my wife's mobile and both get the same message. 

 

As far as I am aware, this is new today. I certainly received calls fine last week.

 

Can you please advise? I am unable to call iD Mobile directly to get resolution as the call centres are closed due to COVID-19, but I do need this resolved. 


3 replies

Userlevel 6
Badge +9

Hi @richardkillip,

We are sorry to hear about that issue, it certainly is a strange one to just randomly occur. Which phone make and model are you using? Also, if you perform a manual network search from within your phones mobile network settings, so you see any difference to the issue?

Once we know a bit more, we’ll see what else we can do to help.

Thank you,
Ryan

Hi @Ryan. Thanks for your reply. I have a Huawei P20 Pro and unfortunately don't quite understand what you asked me to do in settings - however, the good news is that the issue seems to have resolved itself and now can receive calls as normal. How strange. But at least people can now call me. 

Userlevel 6
Badge +8

How odd.

Well do let us know here if you have any further issues @richardkillip, we’ll do all we can to help from there as needed.

Reply