Solved

Signal/network Issues

  • 4 March 2020
  • 7 replies
  • 252 views

Hi I was dealing with somebody on the live chat but got cut off and it has now closed. I am unable to receive any signal in any location. My phone was tested in store and they said not an issue with the phone so gave me a replacement sim card.  I have activated this, waited at least an hour, restarted my phone several times and it made no difference.  I have also tried removing and re-inserting this sim card (it is definitely fitted correctly) I am paying around £30 every month and tied into a contract for a phone that doesn't work!  It has resulted in being unable to make emergency calls.  Are you able to help please?

icon

Best answer by Saidomenas 12 April 2020, 09:09

Hi, 

 

I have no signal nor network coverage. I can see my phone picking up the signal in some areas while I'm driving. However I have none what so ever where I live. 

Phone is absolutely useless....nobody can get a hold of me…

 

I want a refund for the last month as I have no service and not willing to pay for it. 

View original

7 replies

Userlevel 6
Badge +9

Hi @Johanna93,

Thank you for getting in touch and we are very sorry to hear about your issue. This issue will be something that we need access to your account for, and we can see that you have contacted us already via Social Media so we would advise remaining in contact with us via that method so we can have this resolved for you as quickly as possible.

Thanks,
Ryan 

Is drop down 

bs247fn

Hi, 

 

I have no signal nor network coverage. I can see my phone picking up the signal in some areas while I'm driving. However I have none what so ever where I live. 

Phone is absolutely useless....nobody can get a hold of me…

 

I want a refund for the last month as I have no service and not willing to pay for it. 

Userlevel 4
Badge +2

Hi @Saidomenas @Vmarin,

I’m sorry to see this post was not responded to.

I’ve sent you a direct message with further information.

Pearl

I have the same issues can anyone help me! 

Userlevel 1
Badge

I've also got the same issue, my 4g signal is currently so weak that it's activated the Chrome browser "lite" mode that only activates when a signal is 2g or worse or a webpage is going to take ten seconds or more to load.

 

It's completely unusable. My contract is up in August. I've been with ID for years but won't be renewing now. No signal and no support, kind of wild.

Userlevel 4
Badge +2

Hi @Sophie hewes @Gutzdorf 

Welcome to the iD Community.

I’ve sent you a direct message with further information.

Pearl

Reply