Question

Wifi calling on iPhone

  • 20 September 2019
  • 6 replies
  • 102 views

I live in a house with thick stone walls where I can neither receive nor send mobile calls when I'm inside. Sometimes, when I'm inside, my iPhone switches automatically—without my doing anything—to 'wifi calls'. This can go on for up to a week, switching automatically between mobile calls and wifi calls as I go in and out of the house. I find this very useful as it means I can always send and receive calls.
However, for other periods of up to a week, it switches when I'm in the house to 'no service' when it can't get a mobile signal. How can I make it switch automatically between the two modes all the time?

6 replies

Userlevel 8
Badge +9
Hello @John Rusell

This is very strange issue. iPhone should always switch automatically between WiFi calls or Mobile calls and choose the one which is stronger. I will ask you few questions to see if we can find correct troubleshooting steps for you.

When your iPhone switches to "no service" are you connected to WiFi?
Did you try to turn your phone off and on when you see "no service"?
Is your iPhone all up to date with iOS updates?
Did you try resetting network settings and reconnecting your iPhone to your WiFi?

Let us know if tried any of these and if they helped you fix your issue.

Kind Regards
Hi Hikari

Yes, my iPhone always picks up wifi when I'm in the house—even when it won't switch to wifi calls.
Yes, switching off and on makes no difference.
Yes, my iPhone is up dated regularly.
Yes, I've tried resetting the network connections. If it's during a period when wifi calls are working it will will work whenever I go somewhere with wifi.

I'm wondering whether it's an issue with id?

Cheers, John
Userlevel 8
Badge +9
Hey @John Rusell

We would need to wait for @Mohammed, @Kash or @Ryan to leave their input here as they might be advise further.

Personally I don't think there will be an issue with iD Mobile, because anything wrong on their side would prevent you from using WiFI Calling at all times. To me, it seems like either your phone or router is being temperamental. Since you have run all troubleshooting steps on your phone, only thing that comes to my mind and potentially could help is to rebooting your router when WiFI Calling doesn't work.

Kind Regards
Thanks, Hikari. I don't mind rebooting the router once as a test, but I wouldnt want to have to do it every time wifi calling doesn't work. As I said, I always have a strong wifi signal in the house and things like whatsapp work fine. The 'week on, week off' thing is peculiar.

Cheers, John
Userlevel 7
Badge +8
Hi @John Rusell just to add the what @Hikari mentioned,

Goto settings/wifi and turn wifi off [not wifi-calling] wait a while then turn it back on again, this resolves it for me! [Do not toggle wifi off from the pull up widget menu this only disconnects the wifi, not the same thing]

Turning the rooter on and off is a very similar thing, all the issue is here is the router and mobile both get confused with the connections.

Try turning DATA off, this can confuse some mobiles and cause Wifi to not work as expected.

All you need to do next time it happens is turn off the wifi from within the iphone settings menu not the pull up widget, wait a while and then put it back on again. Airplane mode can sometimes kick the mobile wifi calling back in but not always very successful...

On the other hand you could have a dodgy router wifi signal, try changing the channel number to something like 12 if you have access to that number otherwise. 1 - 11 always have issues with overlapping however if your on 5ghz wifi, then signal wont be an issue.
Userlevel 5
Badge +6
Hi @John Rusell, did you manage to notice if rebooting the router helped here?

If it did, that could imply that possibly your router is building up too much cache in it's memory and that certain features are not working until cleared there.

You may have options within your router to clear the cache more frequently, though you'd need to speak to your internet service provider -or- router manufacturer in order to find out more there.

Nothing would be toggled or changed on our side in particular that should make you lose Wi-Fi calling as an option you see.

Reply