Solved

bad signal everywhere


Userlevel 1

Hi,

This is my first time with ID mobile and ever since I've had it I've not been able to make any calls as no one can hear me on the other side, I can hear them perfectly fine but they don't hear me at all. I don't think there is a mask down in the area? Any ideas how to fix this because I can't call anyone  for help? 

 

Thank you

Trev.

icon

Best answer by Mohammed 7 June 2021, 17:52

Hello @Trevla,

The area is showing Good Outdoor and Limited Indoor coverage so it does seem to be the level of coverage we’d expect in the area.

If you are still within the returns conditions and you don’t think you’d be able to use this, we’d suggest a return here based on the coverage we can see.

 

Mohammed

 

 

View original

12 replies

Userlevel 6
Badge +4

Hi @Trevla 

We are sorry to hear this. Have you tried entering your sim card in another phone and then tried calling someone to see if you experience the same issue?

-Mohsin

Userlevel 1

Hi mohsin, 

I haven't got another phone to try that with but my phone is new and calling on Facebook messenger is fine so I know its not the phone, it's just normal phone calling that don't work for me, sometimes I gotta Stand in certain places for people to hear me just a little bit, it's frustrating trying to get people to hear me, my signal bar is always one or two as well

 

Userlevel 5
Badge +1

Try entering your postcode here:

http://www.three.co.uk/support/network_and_coverage/network_support

 

Does it show any problems in your area?

Userlevel 1

Hi thanks for providing me that It, however It says there's no reported problems in my area (sn22nq) 

Userlevel 5
Badge +1

Ok, do you have 4G signal or 3G signal when you experience these issues? Maybe try disabling 4G and try making some calls over 3G only? Failing that, your last option is to try your sim in a different handset.

Userlevel 1

I have 4g signal sometimes just "H" I haven't got another phone to try it on but I will give the 3g thing a try 

Userlevel 1

Changing my signal mode to 3g makes my signal drop to none and then one after a while, think I'm just in a bad area for I'd mobile 

Userlevel 5
Badge +1

Maybe, have you tried doing a network reset?

What phone do you have? On my Samsung device it’s here:

Settings > General management > Reset > Reset Network settings

Userlevel 6
Badge +4

Hi @Trevla 

I have also checked the coverage in your area and seems like no issues are showing. If you are able to make calls through Facebook Messenger fine but not voice calls through your sim then it seems like this could potentially be a software fault on your phone. Please can you do an up to date back up on your phone and peform a Factory restore, this will elinate any software faults on your phone. Please let us know once you have tried this.

-Mohsin

Userlevel 1

Reset my network settings, seems to be working now :) thanks for the help guys

Userlevel 1

I thought it was fixed but it's not, some people can hear me others can't, I'm not gonna reset my phone to factory defaults because its literally a new phone and only just set it up last week, I guess it's just rubbish signal for me where I am. 

Userlevel 8
Badge +9

Hello @Trevla,

The area is showing Good Outdoor and Limited Indoor coverage so it does seem to be the level of coverage we’d expect in the area.

If you are still within the returns conditions and you don’t think you’d be able to use this, we’d suggest a return here based on the coverage we can see.

 

Mohammed

 

 

Reply