Solved

Old number hasn't transferred to iD SIM?

  • 15 October 2018
  • 10 replies
  • 1158 views

Userlevel 1
Hi all, A few weeks ago I went through the process of transferring my number from my old SIM (on EE) to my new iD one, by entering its PAC code in My Account as suggested. I can see that my old number is now displaying in My Account, though my iD SIM doesn't seem to have picked up that old number as I would have expected it to. Only just realised today! Any suggestions on how to rectify this gratefully received. Best wishes, Ben
icon

Best answer by Mohammed 14 February 2019, 16:47

Ooh has anyone got an answer to this my newly ported number is coming up as ID number even though I’ve had confirmation that porting was successful ...

Hey @Springtime,

We never heard back from OP regarding this and so we'll mark this topic as resolved.

I've replied to you on your topic you made, I think this will resolve the issue.
If you still need support, just reply on your topic directly 😀

Mohammed
View original

10 replies

Userlevel 3
Badge +2

Hi @Minty1

 

How long ago did you provide your PAC code? Does your old SIM that had your desired number on it still work?

 

Will

Hello. I gave my PAC code just under a week ago and yes my old SIm still works in my old phone.

I’ve had the same issue. My old number does not work with sms

Userlevel 6
Badge +8

Please get in touch with our Customer Services Team if that’s the case @Mbow 

Through one of the following:

Dialling 0333 003 7777 for our Customer Services Team.


Reaching our Live Chat Team here: https://www.idmobile.co.uk/help-and-advice/contact-us


Facebook (https://www.facebook.com/idmobileuk/?ref=br_rs)


Twitter (https://twitter.com/iD_Mobile_UK)



If you're choosing to email us, please include in your email your iD Community username, your full name, home address and postcode, mobile number, and email address.


 

Userlevel 1
Ooh has anyone got an answer to this my newly ported number is coming up as ID number even though I’ve had confirmation that porting was successful ...
Userlevel 7
Badge +9
Ooh has anyone got an answer to this my newly ported number is coming up as ID number even though I’ve had confirmation that porting was successful ...

Hey @Springtime,

We never heard back from OP regarding this and so we'll mark this topic as resolved.

I've replied to you on your topic you made, I think this will resolve the issue.
If you still need support, just reply on your topic directly 😀

Mohammed
Userlevel 6
Badge +9
Hi @Ben Dunn,

When you mention that the iD SIM is not picking up on the old number, what do you mean exactly; are your calls & texts outgoing from the ported number or the new iD number?

Ryan
Hi there I also have this issue. I entered the PAC code and got a confirmation 36 hours later to say that the number had transferred- I clicked to confirm that I wanted to keep my old number, but now only my ID mobile number is showing on outgoing calls and texts. Though I am receiving calls and texts to my old number ( the one I want to keep ). I can’t find a solution from the discussion thread above please help!!
Userlevel 4
Badge +6

Hi Kate0309, it sounds like your port may be split if you are effectively using 2 numbers.

Can you please email us  so we can help get this sorted for you.

We'd recommend you restart your phone and test using the SIM in a different phone if possible first to confirm the situation.
Sending a text to yourself is a good thing to test but if you are using an iPhone, use normal SMS instead of iMessage as that can further complicate things if the wrong number is set up..

-Phil

Hi all, A few weeks ago I went through the process of transferring my number from my old SIM (on EE) to my new iD one, by entering its PAC code in My Account as suggested. I can see that my old number is now displaying in My Account, though my iD SIM doesn't seem to have picked up that old number as I would have expected it to. Only just realised today! Any suggestions on how to rectify this gratefully received. Best wishes, Ben

I’m having the same problem too!  Please could someone advise me what I need to do to complete the full change over process? I’m stuck! Thank you.

Reply