Solved

Replacement SIM apparently activated but not working

  • 7 February 2019
  • 1 reply
  • 167 views

I recently lost my phone ( including the SIM card) and ordered a replacement SIM as well as a SIM-free phone, after blocking the old phone and SIM card. The new phone is working perfectly, and also recognises the SIM when it is inserted. I have activated the SIM using my online ID mobile account, and received a message saying that my new SIM card had been activated. However, 24 hours later I have no network, cannot make calls, and cannot use data. My area has very good 3G/4G coverage, and I have cleaned and re-inserted the SIM card many times. When looking in my phone settings, the number is unknown, the network has no service, and the mobile network type is unknown. I have unblocked the SIM card, do I also need to unblock the old phone? I assumed that since that device is lost it would be unwise to unblock it.
icon

Best answer by Kash 8 February 2019, 14:13

Hi @mtaylor06,

Sorry to hear that your SIM isn't working but I'm sure we can get down to the bottom of this. It may be that your account is not fully active due to the SIM being reported as lost. However if you contact our Live Chat Team here somebody can get this looked into and sorted for you.

Kash
View original

1 reply

Userlevel 2
Badge +5
Hi @mtaylor06,

Sorry to hear that your SIM isn't working but I'm sure we can get down to the bottom of this. It may be that your account is not fully active due to the SIM being reported as lost. However if you contact our Live Chat Team here somebody can get this looked into and sorted for you.

Kash

Reply