Solved

I'm having issues Roaming?


Userlevel 1
While on holiday in Madeira recently I could not access the internet on my mobile phone except through Wifi. Roaming and International are switched on in my account and on my phone Aeroplane mode was switched off and data roaming was switched on. How can I access internet when abroad in future.
Thanks

[EDIT: Topic Title changed to provide more information]
icon

Best answer by Bartle45 11 June 2018, 17:22

Thanks Mohammed. I now have a new phone which has installed your Id APN settings automatically and everything is now working fine. Many thanks for all your help.
Howard
View original

15 replies

Userlevel 6
Badge +6
Hello @Bartle45,
Welcome to the iD Community.

The main things to check when going abroad are:

  • Data Roaming turned on in the iD Account
  • Data Roaming turned on for the handset
  • Correct iD Access Point Name (APN) settings
  • Ensuring the phone hasn't reached the cap (if roaming in a non-inclusive country)
Sometimes a manual network search can also help.

Take a look at this great topic for more info:
https://community.idmobile.co.uk/coverage-international-roaming-24/how-to-prepare-your-phone-for-a-trip-abroad-182

Mohammed
Userlevel 1
Thank you
I had data roaming turned on in my account and on my phone.
The roaming cap did not apply.
How do I check I have the correct ID APN settings please.
Userlevel 6
Badge +6
Hey @Bartle45,

The correct APN settings are found in the thread: https://community.idmobile.co.uk/coverage-international-roaming-24/how-to-prepare-your-phone-for-a-trip-abroad-182

Which handset do you currently have?

Mohammed
Userlevel 1
Moto G. Android 5.1
Userlevel 6
Badge +6
Hello @Bartle45,

Can you try:
Settings > More > Mobile Networks > Access Point Names

Can you send us a screenshot of what's showing here?

Mohammed
Userlevel 1
Name: 3
APN: three.co.uk
Proxy: Not set
Port: Not set
Username: Not set
Password: Not set
Server: Not set
MMSC: http://mms.um.three.co.uk:10021/mmsc
MMS proxy: mms.three.co.uk
MMS port: 8799
MCC: 234
MNC: 20
Authentication type: None
APN type: default,mms,supl
APN prtocol: IPv4
APN roaming protocol: IPv4
APN enable/disable: APN enable (greyed out)
Bearer: Unspecified
MVNO: None (greyed out)
MVNO value: Not set (Greyed out)
Userlevel 6
Badge +6
Hello @Bartle45,

iD runs off the Three UK network.

What happens is when you put the SIM in for the first time, this can sometimes register the Three UK APN settings instead of the iD ones. It's fine to use when in the UK but roaming isn't supported.

Can you deleted these APN settings and add a fresh new one with the following:

Name: iD
APN: id
Username:
Password:

MMSC: http://mms.um.idmobile.co.uk:10021/mmsc
MMS Proxy: mms.idmobile.co.uk
MMS APN Username:
MMS APN Password:
MMS Port: 8799

* anything with should be left blank

Select this APN and a quick restart should fix it.

Mohammed
Userlevel 1
Mohammed
Many thanks for this which is very useful. Hopefully it will work when I am next abroad
Howard
Userlevel 6
Badge +6
No problem @Bartle45

If you do have any issues at all, you can just message us here and we'll try help as best we can!

Mohammed
Userlevel 1
Mohammed
Since changing the APN settings I can only now access the internet via wi-fi. When not on wi-fi I get the message "No Internet Connection".

Could you please let me know what settings I need to connect to the internet without wi-fi

Just to recap my current APN settings are below.

Name: iD
AP: iD
Proxy: Not set
Port: Not set
Passworrd: Not set
Server: Not set
MMSC: http://mms.um.idmobile.co.uk:10021/mmsc
MMS proxy: mms.idmobile.co.uk
MMS port: 8799
MCC: 234
MNC: 20
Authentication type: None
AON type: default,mms,supl
APN protocol: IPv4
APN roaming protocol: IPv4
APN enable.disable: APN enable (greyed out)
Bearer: Unspecified
MVNO type: None (greyed out)
MVNO value: Not set (greyed out)
Userlevel 6
Badge +6
Hey @Bartle45,

Could you try deleting all current APN settings.

Then add a fresh new APN setting with the following:Name: iD
APN: id
Username:
Password:

MMSC: http://mms.um.idmobile.co.uk:10021/mmsc
MMS Proxy: mms.idmobile.co.uk
MMS APN Username:
MMS APN Password:
MMS Port: 8799

* anything with should be left blank


PLEASE NOTE: it's important to delete and re-add these. Amending your current APN settings will NOT work. The settings may be exactly the same but deleting and re-adding seems to trigger a reset on the network

Mohammed
Userlevel 1
Sorry but I have done this - deleted all APN and added back settings as instructed. I still cannot get an internet connection without wi-fi.
I have not added anything against User Name and Password. Adding the above also automatically adds MCC: 234 and MNC: 20 and APN protocol IPv4. Everything else is NOT set.
APN enable/dosable is greyed out. so cannot be turned on. Is this important.
Userlevel 6
Badge +6
Hey @Bartle45,

You'll only need to change the settings advised above.
Anything else should be left to it's defaults.

What is the name of the APN setting? Is this written as "iD" (Case sensitive)
and the second box under APN as "id" (Case sensitive)

Anything that's left blank should be left blank, some settings may be retrieved automatically.

Have you tried the SIM in another handset?

Can you attach a screenshot of these here?

Have you tried powering down the handset, removing the SIM, powering this back up then re-inserting the SIM?

Mohammed
Userlevel 1
Thanks Mohammed. I now have a new phone which has installed your Id APN settings automatically and everything is now working fine. Many thanks for all your help.
Howard
Userlevel 6
Badge +6
Thanks Mohammed. I now have a new phone which has installed your Id APN settings automatically and everything is now working fine. Many thanks for all your help.
Howard


Pleased to hear this @Bartle45,

Thanks for confirming this.

Mohammed

Reply