my phone doesnt work abroad on ID

  • 27 November 2019
  • 4 replies

I have Samsung galaxy s7 previously on 3. 

And it worked great. 

However since using ID I have had many problems using it on holiday. 

First time was in Malta where I couldn't use data. 

When I came home i had a chat online with ID and they gave me settings to change. But said I could only do this while abroad.

Then in USA I couldn't sent or get texts or make calls, data was turned off as it was too expensive there. 

So I tried changing the settings but still didn't work. I even got notification that SIM was not allowed.  I had to turn phone off and on to get network  and tried changing networks to t mobile as advised by I'D but it always referred back to at&t then SIM mot allowed came back  

on returning to UK I transferred planes in Amsterdam and it still wouldn't work, there no data.


I have a few trips planned to eurooe in next few months and it's really important that I have data and network.


I appreciate any help.


4 replies

Userlevel 6
Badge +8

Hi @Heathermo,

I am sorry to hear about those issues! The APN settings within the phone may still be showing ones from the Three network and therefore, they will not work abroad. They work within the UK still because we use Three for our network services.

On your phone, if you head to the mobile network settings and locate the APN settings (Access Point Names), you should press the menu button and then the ‘Reset to Default’ option. Choose iD Mobile once done and then it should work fine when abroad next time.



I have done this already. It doesn't work. 

Userlevel 7
Badge +8

Hello @Heathermo,


We already have a great topic here:


Have you checked this?

Key tips:


Ensure the spend cap is raised to allow spend when in a non-inclusive Roaming destination

Ensure Roaming is enabled in the iD app/account

When dialling UK numbers, use +44 instead of 0. So 0333 003 7777 is +44333 003 7777

Turn on Data Roaming in the phone when you want to use DATA

Ensure you’re set-up on the iD APN settings