Solved

Green texts problem

  • 3 August 2020
  • 9 replies
  • 132 views

Why can I not send green texts on my iphone5S sometimes? I just get the red exclamation mark and undelivered. Very frustrating!

icon

Best answer by Ryan 5 August 2020, 16:59

Hi @Kenneth,

When you mention that it only happens with certain numbers, with those numbers, does it happen with every text you try to send to them? Also when that happens, do you still have a network signal? The green messages would indicate that they are not being sent via iMessage as you mention, so there could be a signal issue.

It might be worth trying the below iMessage steps anyway, just in case this helps the situation by refreshing the phones settings:

1)    Turn off iMessage (Settings > Messages)
2)    Restart your phone (by pressing and holding the on/off button)
3)    Tap Settings > Phone > My Number and confirm that it is correct. 
4)    If it is not correct, please enter the correct number
5)    Turn iMessage back to On (Settings > Messages)
6)    Finally, go to Settings > Messages > Send & Receive and see if the correct number is displayed under “Start new conversations from:”. 

Please let us know how it goes.

Ryan

View original

9 replies

Userlevel 7
Badge +9

Hello @Kenneth,

Is this via iMessage?

 

Have you just joined iD Mobile and recently ported your number in?

 

Is this for all numbers or some?

Mohammed

It only happens with green texts not blue iMessages. no I have not recntly joined. It only happens with certain numbers (green text numbers). 

Userlevel 7
Badge +9

Hi @Kenneth,

When you mention that it only happens with certain numbers, with those numbers, does it happen with every text you try to send to them? Also when that happens, do you still have a network signal? The green messages would indicate that they are not being sent via iMessage as you mention, so there could be a signal issue.

It might be worth trying the below iMessage steps anyway, just in case this helps the situation by refreshing the phones settings:

1)    Turn off iMessage (Settings > Messages)
2)    Restart your phone (by pressing and holding the on/off button)
3)    Tap Settings > Phone > My Number and confirm that it is correct. 
4)    If it is not correct, please enter the correct number
5)    Turn iMessage back to On (Settings > Messages)
6)    Finally, go to Settings > Messages > Send & Receive and see if the correct number is displayed under “Start new conversations from:”. 

Please let us know how it goes.

Ryan

Thanks Ryan. I have done all that and found that it wasn’t my number under My Number. I assume it was the number of the person from whom I bought the phone a couple of years ago on eBay! I haven’t tried any texts yet but will let you know.

Just something else. It didn’t send green texts when I was in the house on my wifi. If I turned the wifi off and the phone found the 4G outside it suddenly pinged and was sent.

Ken

Userlevel 7
Badge +9

Hi @Kenneth,

The number not being correct could have been the cause of the issues mentioned. If you can let us know once you have tried it now that it has been updated, included on and off WiFi, we’ll see what else we can suggest if it doesn’t work.

OK. Further to that, a person who normally has no trouble texting me said that his text to me this morning didn’t send. The plot thickens…

 

Userlevel 5
Badge +7

Hi @Kenneth,

 

Did you try doing what Ryan advised?

 

Will

I will try then let you know...

Userlevel 5
Badge +7

Cheers @Kenneth.

 

Will

Reply