Solved

messages not sending

  • 19 October 2020
  • 1 reply
  • 44 views

I have recently changed to id mobile and kept my number from my old network provider. Every time I now send a text message I receive a failed to send message but the message goes to the recipient 2/3 times. 

icon

Best answer by Kevin 21 October 2020, 17:33

Hi there @Benno 

Are you using an iPhone per chance?

If so, could you try the following

Could you go to Settings > [Your Profile] > Name, Numbers, Emails
and then ensure within there that the correct number is showing?

You may possibly need to log out of iCloud or Apple ID in order to make the change.


Another method that has worked in the past for others is as follows...
Turn off the iPhone > Take out your SIM
Turn the iPhone back on (no SIM) > Leave on for a minute or so.
Pop the iD Mobile SIM back in the iPhone > Turn back on.


====

Please can you try to follow these steps to see if it helps with your non-iPhone SMS messages?

1)    Turn off iMessage (Settings > Messages)
2)    Restart your phone (by pressing and holding the on/off button)
3)    Tap Settings > Phone > My Number and confirm that it is correct. 
4)    If it is not correct, please enter the correct number
5)    Turn iMessage back to On (Settings > Messages)
6)    Finally, go to Settings > Messages > Send & Receive and see if the correct number is displayed under “Start new conversations from:”. 

 

If not, what phone are you using?  Have you restarted the phone at all since the number ported over?

View original

1 reply

Userlevel 6
Badge +9

Hi there @Benno 

Are you using an iPhone per chance?

If so, could you try the following

Could you go to Settings > [Your Profile] > Name, Numbers, Emails
and then ensure within there that the correct number is showing?

You may possibly need to log out of iCloud or Apple ID in order to make the change.


Another method that has worked in the past for others is as follows...
Turn off the iPhone > Take out your SIM
Turn the iPhone back on (no SIM) > Leave on for a minute or so.
Pop the iD Mobile SIM back in the iPhone > Turn back on.


====

Please can you try to follow these steps to see if it helps with your non-iPhone SMS messages?

1)    Turn off iMessage (Settings > Messages)
2)    Restart your phone (by pressing and holding the on/off button)
3)    Tap Settings > Phone > My Number and confirm that it is correct. 
4)    If it is not correct, please enter the correct number
5)    Turn iMessage back to On (Settings > Messages)
6)    Finally, go to Settings > Messages > Send & Receive and see if the correct number is displayed under “Start new conversations from:”. 

 

If not, what phone are you using?  Have you restarted the phone at all since the number ported over?

Reply