Solved

Texts not sending

  • 22 January 2019
  • 5 replies
  • 197 views

Hi. My iPhone sends texts by iMessage only. It won’t send message texts to other phones such as Android, etc.

why is this?

thanks
icon

Best answer by Lenkijah 26 October 2020, 22:54

Hi Will, 

Thanks for replying. Miraculously the problem cleared up. Not sure what the problem was but there was series of messages over 2 days I didn't realise hadn't sent. It was likely a network problem. Thanks for taking the time to reply.

 

Lenkijah

View original

5 replies

Userlevel 7
Badge +9
Hi @jllew58,

Please can you check your iMessage settings within the phone to ensure that the phone number stored matches your current mobile phone number?

Another thing to try would be to sign out of iMessage, restart your phone and then sign back in to see if everything syncs up. I understand that iMessage is working fine, but doing this will refresh the whole text messaging aspect of your phone.

Let me know how it goes.

Ryan

Hi. For the last few days I'm having problems with texts. I'm getting the message underneath "not sending. Top to send again". Can you help? 

Userlevel 5
Badge +7

Sure thing @Lenkijah,

 

Have you ported a new number over to us recently? Are you using an iPhone? If so, have you tried toggling iMessenger on and off?

 

Will

Hi Will, 

Thanks for replying. Miraculously the problem cleared up. Not sure what the problem was but there was series of messages over 2 days I didn't realise hadn't sent. It was likely a network problem. Thanks for taking the time to reply.

 

Lenkijah

Userlevel 7
Badge +9

Glad to hear that @Lenkijah 

 

It’s worth checking the following just incase this is the route cause:

 

1)    Turn off iMessage (Settings > Messages)
2)    Restart your phone (by pressing and holding the on/off button)
3)    Tap Settings > Phone > My Number and confirm that it is correct. 
4)    If it is not correct, please enter the correct number
5)    Turn iMessage back to On (Settings > Messages)
6)    Finally, go to Settings > Messages > Send & Receive and see if the correct number is displayed under “Start new conversations from:”. 

 

Mohammed

 

Reply