We've launched a new iD Mobile app!

  • 17 March 2024
  • 60 replies
  • 10928 views
We've launched a new iD Mobile app!

Show first post

60 replies

Userlevel 2

Yet another new update for the iD mobile app. And STILL the plan page doesn’t work. Same old same old, “oops… something went wrong” and the try again button. Press that and it just repeats itself. Beyond a joke now.

I was abroad and needed to check what my data allowance was and whether I was about to exceed it but can’t log onto anything that will give me this information.

Also thinking of changing my tariff but can’t do so.

Any advice.

Userlevel 8
Badge +5

Hi @AngieL 

 

Have you registered to the new iD Mobile app? You won’t be able to log in before registering.

 

Tom

Tom

I’ve tried but it won’t get any further than “Say hello to the new iD mobile app”!!

And I’ve just tried again and was told I was in a queue and would have to wait 38 minutes!!

😠😡

Userlevel 2

I have been trying for two weeks to access my account and IT’S STILL NOT WORKING!!!

If I could actually get on, I’d cancel my contract but maybe that’s the plan - no-one can cancel!

Sorry to say that this new system does not work. As a pensioner it is very confusing,I now do not know if I have my original account and another which I did not ask for.please go back to the original system which has worked for years.

Mick Palmer 

I can’t register on the app.  I've deinstall/reinstalled! When I put in the one time passcode emailed it says its wrong. I need to set up in the app ASAP.  help!

Userlevel 8
Badge +5

Hi @Abigailmstewart 

 

We believe this issue to now be resolved, please try again.

 

 

Tom

What a total shambles (aka cluster….)

Oops… something went wrong. Try again, and again and again .. but still it doesn’t work.

In a browser (Firefox onW10) after clicking “Getting Started” repeatedly I can only log-in 1 time in 10 !!! And on the App (Android) I have NEVER been able to log-in.

Similarly downloading Bills is an impossibility (Russian Roulette is more reliable!) - as is Changing Payment details.

A simple 3 minute task has taken me over an hour - and I’ve still not yet managed to achieve my simple objective.  Unbelievable. I thought “tech” was supposed to make our lives easier.  Well it did when I worked in IT but obviously today’s programmers don’t know how to programme!  Senior management should be fired for allowing such flakey software to “go live”.

 

Reply