Solved

wifi calling on samsung j6 has stopped


J6 (2018) had wifi calling until a few days ago. It is on the supported list. Have recently ported number from 3 because they stopped their 3 in touch app. Have tried resetting router and network settings, and switching everything off and on. No mobile signal in our area so wifi calling essential. What can I do to make it work again?
icon

Best answer by Mohammed 30 May 2019, 16:55

Hey @Cmus,

Are you on the latest version of the software?

When you say it's not working, do you mean that it's never connecting to WiFi Calling at all regardless of if you have no service?
Usually, WiFi calling kicks in when you drop down to below a set signal, it won't always be on by default.

Have you tried putting your phone in flight mode and then turning ON WiFi and seeing if WiFi Calling connects?

Mohammed
View original

16 replies

Userlevel 6
Badge +6
Hey @Cmus,

Are you on the latest version of the software?

When you say it's not working, do you mean that it's never connecting to WiFi Calling at all regardless of if you have no service?
Usually, WiFi calling kicks in when you drop down to below a set signal, it won't always be on by default.

Have you tried putting your phone in flight mode and then turning ON WiFi and seeing if WiFi Calling connects?

Mohammed
Userlevel 6
Badge +6
Try turning mobile DATA off, this can confuse some mobiles and cause Wifi to not work as expected.

The fallback settings for the internet do not always work as they should.
Also known as preferred internet settings.

Might be worth trying samsung software update from settings about!!!

otherwise please check video HD Voice is ON. should be enabled by default but if wifi calling is not working try turning it off.

Samsung - Turn Video Call On / Off - HD Voice
  1. From a Home screen, tap the Phone icon (lower-left). ...
  2. Tap the Menu icon (upper-right).
  3. Tap Settings.
  4. Tap the Video Calling switch to turn on or off .
Thanks guys. The phone does not connect to wifi calling at all despite no mobile signal.

Switching to flight mode then switching wifi on solved the issue initially. But I switched flight mode off again, and now repeating your instruction won't switch wifi calling back on.

Switching data off did not work. Samsung software is fully up to date. There is no switch for video calling or HD voice.

Wifi calling seemed to work fine until I ported my number from 3.

Anything else I can try?
Wifi calling has reappeared! Have not changed any settings since my last post. Fingers crossed it will remain available. Thanks for your help.
I replied too soon. Wifi calling disappeared again soon after my last post and has not return. Could this be linked to slow broadband, typically c.3mbps?
Userlevel 4
Badge +6
Hi Cmus, if the problem is intermittent like this, then it's unlikely to be a setting on your phone. Are you able to test using another WiFi connection as your assumption regarding slow broadband speed is likely to be correct.

-Phil
I turned on flight mode and wifi and connected to wifi at work. Still no wifi calling.
Userlevel 5
Badge +6
We're terribly sorry to hear we've still not got to the bottom of this one for you here @Cmus as we'd always hope.

So in this case it looks as though it'll be best for us to get some further advice from our Tech Team for you. Though in order to do this we'll need you to contact us to provide some further details so we can bring up your iD Mobile account.

If you could get in touch with us either through:

Dialling 0333 003 7777 for our Customer Services Team.
Reaching our Live Chat Team here: https://www.idmobile.co.uk/help-and-advice/contact-us
Contacting our Social Media Team on Facebook or Twitter
Emailing our office at: communitysupport@idmobile.co.uk

If you're choosing to email us, please include in your email your iD Community username, your full name, home address and postcode, mobile number, and email address.

Thanks
Thank you. Very helpful lady (Leanne) in local CW shop contacted tech guys via customer services for me. I followed their subsequent advice re APN configuration settings. Still no joy. Will give it 24 hours then contact again.
This is far from solved! The wifi calling icon shows sometimes but even when it does amd I try to call I get the error message 'mobile network not available'. I will have access to superfast broadband in a couple of days and will try again. But now getting fed up. Without wifi calling, id is all but useless to me.
Userlevel 4
Badge +6
Hi Cmus, we hope an improved broadband connection does help you with this.

Can you see in the settings if you are provided with the option for preferred call type? WiFi or Mobile ?

-Phil
Superfast makes no diff. No wifi calling symbol at all. Tried in plane mode with wifi on, zip. With plane mode off there's a strong phone signal.

There's no option for preferred call type in settings. Did find wifi calling buried in apps but it is switched on. Have cleared cache, forced stop and restarted. Still zip.
Have now changed so many settings I've lost the plot on which is which!
Just tried link above to live chat:
The requested URL was rejected. Please consult with your administrator.

Your support ID is: 10948148143385723523

Then called customer services. High call vol. Wonder why!
Userlevel 4
Badge +6
Hi

You may be able to try to check the settings using the Android menu but we must stress that you should not change any settings unless you are confident.
There could be a potential to cause errors on the phone this way.

Start by placing a call to *#*#4636#*#* to load the menu.

Take a look in "Phone Information" to see if there is anything about WiFi calling being active or not.

Then press back or home to leave the menu.

Phil
Thanks Phil. Tried placing call to *#*#4636#*#* using normal phone app whilst I had phone and 4G signals. Nothing happened. No dialling, no menu. Would the menu show automatically?

I don't think I've changed any underlying settings so far.

Thanks for staying with me on this! 'Tis appreciated.
Carol
Userlevel 6
Badge +6
Hello @Cmus,

I can see that you've gotten in touch via email regarding this and we'll investigate this there with you.

Mohammed

Reply