Solved

Unable to log in on PC

  • 9 April 2019
  • 4 replies
  • 239 views

I am new to ID.
I had some difficulty getting going because my phone is too old for the ID app (Android 4.4) and I could not register on the PC. I eventually succeeded on an iPad.
However, I am still unable to access my account from the PC. I have tried Chrome, Edge and IE. On two of them the "login" button remains greyed out even after entering phone number and password, on the third on it is not greyed out but still does not work.

Any solution? (Apart from do it all on the iPad!)

Thanks
icon

Best answer by NormB 16 April 2019, 17:34

I sorted it.
The problem was that I was using a password app that allows drag and drop of username and password from the app to form input boxes. Most of the time this woks fine but some input boxes (usually the password one) do not let you do it and you have to use a copy/paste method. In the ID form it appeared to work - it dragged and dropped and displayed the usual "*****", but the login button remained grey. When I copied and pasted instead of drag/drop it then worked.
Sorry if I wasted anyone's time.
View original

4 replies

Userlevel 8
Badge +6
Hi @NormB

I am using Opera browser to access my ID Mobile account and I can login without any issues. I have had some issues with Google Chrome like when I tried to filter my upgrade option to see what's available for me they all disappeared but on Opera works fine for me.

Kind Regards
Userlevel 6
Badge +6
Hello @NormB,

To Log-into your account, you only need to enter the username and password.

If you're registering, that's when you'll need the iD Mobile number.

Can you try going to https://my.idmobile.co.uk/ to log-into your account.

Mohammed
I sorted it.
The problem was that I was using a password app that allows drag and drop of username and password from the app to form input boxes. Most of the time this woks fine but some input boxes (usually the password one) do not let you do it and you have to use a copy/paste method. In the ID form it appeared to work - it dragged and dropped and displayed the usual "*****", but the login button remained grey. When I copied and pasted instead of drag/drop it then worked.
Sorry if I wasted anyone's time.
Userlevel 6
Badge +6
Hey @NormB,

You didn't waste anyone's time and hopefully, marking this as best answer you're able to help someone else with the same issue!

Thanks for letting us know. 😀

Mohammed

Reply