Solved

Texts not arriving

  • 12 January 2021
  • 24 replies
  • 177 views

Userlevel 1

Hello. I’ve just upgraded to a Motorola e6s with an iD SIM and with a new number, but for some reason texts sent to it while the phone is turned off aren’t there when I switch it on. Is there something I need to activate to ensure I don’t miss any texts that are sent while the phone is switched off? Thank you for your help.

icon

Best answer by Kevin 28 January 2021, 18:27

We’ll send you a private message now @Cosmic Hobo so that we can probe our Tech Team for further suggestions or have this looked at further.

Simply click on your profile icon in the top right, then go to your private messages.
 

View original

24 replies

Userlevel 6
Badge +8

That’s an odd one @Cosmic Hobo.

 

So it’s not a case that they’re delayed, they just don’t come through at all? 

 

Is this happening from one particular number, or is it a few different ones? Does voicemail function work when it’s turned off?

 

Will

Userlevel 1

Hello @Will. Thanks for getting back to me. Yes, that’s correct. The texts don’t come through at all.

I’ve texted from my other phone a few times while my new one (with the iD SIM card) was off and none of them have come through.

I haven’t given the new number to anyone else yet as I want to get used to the new phone first and make sure that everything is working OK. As that isn’t the case with texts, I didn’t want to give the number to anyone else until the issue was fixed, so I’m unable to tell if it happens from other numbers.

However, I think it’s worth noting that WhatsApp messages that I’ve sent from my other phone while the new phone is off come through OK once it’s switched on, so it can’t be a problem with the new phone and must surely be something to do with the iD network.


I disabled voicemail as soon as I got my new phone as I won’t need it.

Thank you for your help with this. I hope it can be resolved, as it’s very frustrating.

@Cosmic Hobo 

Userlevel 1

Hi again @Will. I thought it might help if I did indeed give my new number to somebody else to try out, and I’m sorry to say that the text that they sent while the phone was off didn’t come through when I turned the phone back on.

So, it is indeed an issue with other numbers as well.

@Cosmic Hobo

Userlevel 4
Badge +3

Hi @Cosmic Hobo 

Please can you try the following

Search for “About Phone” in Settings
Click into “Status”
Click into “Network”
(Select relevant SIM)
Set the “SMS center number” to “+447782000800”
 
Let us know how you get on once you have tried this.

 

 

-Mohsin

Userlevel 1

Hi @Mohsin 

Thanks for your message.

However, About phone in Settings only yields the following:

Phone number (sim slot 1), Phone number (sim slot 2), SIM status (slot 1), SIM status (slot 2), Model & hardware, IMEI (sim slot 1), IMEI (sim slot 2), Android version, IP address, Wi-Fi MAC address, Bluetooth address, Legal information, Regulatory labels, and Build number.

There isn’t an option for Status and, hence, Network or SMS center number.

Searching for SMS center number doesn’t yield anything either.

Are you able to suggest anything else, please? I very much appreciate your assistance.

@Cosmic Hobo 

Userlevel 6
Badge +8

Hi @Cosmic Hobo 

 

We did have some network issues relating to the sending and receiving of text messages on Saturday, but these have since been fixed. Are you still having the same issue, or is it resolved now?

 

Will

Userlevel 1

Hi @Will 

A text sent today while the phone was off arrived 19 minutes after it was switched on. I’m not sure it should have taken that long to turn up (it’s been pretty much instantaneous with other phones that I’ve had), but nevertheless at least it did arrive :) Hopefully this means we’re on the road to a full resolution. I still can’t find “SMS center number” on the phone, though.

Many thanks for your continued help.

@Cosmic Hobo 

 

Userlevel 7
Badge +9

Hey @Cosmic Hobo,

Try calling *#*#4636#*#*. 

I believe this should bring up a list of numbers and one of them should read SMSC

 

Mohammed

Userlevel 1

Hi @Mohammed 

Thanks for the suggestion. However, calling the above simply brings up a Testing screen with options for Phone information, Usage statistics, and Wi-Fi information, and none of them give the SMSC.

@Cosmic Hobo 

Userlevel 7
Badge +9

Hello @Cosmic Hobo,

Tap on Phone information

Scroll down to the bottom and where it says SMSC put in +447782000800 and click Update

If that doesn’t work try 07782000800

 

I can’t remember if you need +44 or not that’s why.

 

Mohammed

 

Userlevel 1

Hello @Mohammed 

Thank you for your continuing efforts to help – they’re greatly appreciated!

I did what you suggested and, sure enough, found SMSC. However, despite clicking on UPDATE, the number didn’t save :frowning2: It had disappeared when I switched the phone back on. (Further down are buttons for OPERATOR PROVISIONING INFO and TRIGGER OPERATOR PROVISIONING, so I tried those as well in case they were relevant but they didn’t work either.)

On the plus side, test texts are turning up, albeit after a while. One that I tried this morning arrived 42 minutes after the phone was switched on, and one that I tried earlier this evening turned up 15 minutes after I switched the phone on. Not ideal, but it’s progress of sorts!

@Cosmic Hobo 

 

 

Userlevel 1

Hello @Mohammed  @Will and @Mohsin 

Things have suddenly got much worse again.This time it took 7 hours 21 minutes for a text to arrive after the phone was switched on! This surely can’t be acceptable. Please can something be done?

 

@Cosmic Hobo

Userlevel 6
Badge +9

We’ll send you a private message now @Cosmic Hobo so that we can probe our Tech Team for further suggestions or have this looked at further.

Simply click on your profile icon in the top right, then go to your private messages.
 

Userlevel 1

Thank you, @Kevin. Just sorting it now.

 

@Cosmic Hobo 

Im getting the same error. When phones off text messages dont alwYs arrive. Ive seen that the sender definately sent it at 9:15 today. Now 15;10 and still nothing 

Userlevel 6
Badge +8

Hi @Ronny5656,

 

How are messages behaving when the handset is switched on?

 

Will

Hello, I’m not receiving any texts at all and need to urgently, for work. I’ve just transferred from EE and noticed that a lot of people are experiencing the same issue. It’s not just texts it’s verification codes as well. There’s nothing else I can try that’s been suggested?

Userlevel 4
Badge +3

Hi @Manderson79 

We are sorry to hear this. Are you able to send text messages? Have you moved from an iPhone to Android by any chance? If so, make sure you have deactivated iMessage for your number. 

-Mohsin

Hi Moshin, thanks for your reply. No I’ve moved from Android to iPhone and can’t receive texts. I can send iMessage to other iPhone users but can’t send or receive SMS?

 

Mike

Userlevel 1
Badge +6

Hi @Manderson79 

Can you try the following steps to see if this helps resolve your text issue? 

1) Try turning off iMessage (Settings > Messages)

2) then restart your phone (by pressing and holding the on/off button)

3) tap Settings > Phone > My Number and confirm that it is correct.

4) If it is not correct, please enter the correct number)

5) then turn iMessage back to On (Settings > Messages)

6) go to Settings > Messages > Send & Receive and see if the correct number is displayed under “Start new conversations from:”

 

Please do let us know how you get on with the above. 

 

Thanks, 

Jade 

Thanks Jade

I’ve already tried this and it hasn’t worked..

Userlevel 1
Badge +6

Hi @Manderson79 

We’ve popped you a message so that we can take a further look into what’s happening here for you. 

Thanks, 

Jade

Hello

Sorry I don’t know where to check to see this message. Where have you popped it? 

Userlevel 4
Badge +3

Hi @Manderson79 

To view the message sent.  Simply click on your profile icon in the top right, then go to your private messages.

-Mohsin

Reply