Solved

Wi-Fi calling issue on S8

  • 20 September 2018
  • 8 replies
  • 176 views

I've had a Samsung Galaxy S8 on i.d. for 2 months.
Wi-Fi calling (the reason I took the contract due to intermittent reception at home) hasn't worked very often from the start. Sometimes not at all (despite having Wi-Fi calling turned on and being next to a Wi-Fi router).

I've been in contact with i.d. on chat and phone. They directed me to Carphone Warehouse who directed me to Samsung who directed me back to i.d. etc.

Finally, I seem to be able to have Wi-Fi calling more often, but in order to get it working I need to manually turn the mobile network mode to 3G only (not 4G/3G/2G auto connect). This means it is not a seamless transition and involves pressing - settings/connections/mobile networks/network mode/ 3G only.
Does anyone know how to make this a quicker process or, even better, know a better more seamless way to have Wi-Fi calling without it being at the expense of 4G because this 'work around' obviously means that when I move away from an Wi-Fi connection I don't have 4G to pick up the slack?
icon

Best answer by Mohammed 22 October 2018, 14:41

Hello @DanT,

Looks like we've been through as much troubleshooting as we can from here so we'll need to access your account to get this raised.

I've PM'ed you with the steps we can take to get this resolved.

Mohammed
View original

8 replies

Userlevel 4
Badge +6
Hi DanT, it's not good to hear about your journey to try and get things working better.

Are you able to check if there's a feature on your phone that switches automatically from WiFi/ Mobile Data?

Settings > Connections > Wi-Fi
Menu, Advanced, Smart network switch.

It may be best to have this off in an effort to maintain your WiFi connection, please let us know if this helps at all.
-Phil
Hi Phil,
Thanks for that but the 'switch to mobile data' toggle is already off.
What it seems I need is a setting for Wi-Fi to be given preference to 3G/4G for calls (when both are available).
Thanks,
DanT
Userlevel 4
Badge +6
Hi Dan, thanks for the response.

In this case, when connected, WiFi would always be used for data but it's not possible to specify this for calls unfortunately.

Have you tested if WiFi calling is more reliable when data is turned off or is it only when set to 3G ?
You may also be able to turn off 4G calling on the device if this changes things.
Settings > Connections > Mobile networks > 4G calling

-Phil
Hi Phil,
I've already had to turn off 4G calling on the device to get Wi-Fi calling to work.
Today Wi-Fi calling has decided not to work anyway. At times my phone has shown no network coverage but Wi-Fi calling has not started working to compensate. At other times my phone has shown 1 or 2 bars of network coverage but I've still missed phone calls from people and only found out an hour after they called when I received a voicemail notification text.
I've turned my phone off and on twice to try to get it working but to no avail.

I think technical at I.D. mobile need to sort something out.

Dan
Userlevel 1
I've the S9 and Wifi calling will only come on when you've got virtually no mobile signal
Userlevel 6
Badge +6
Hi Phil,
I've already had to turn off 4G calling on the device to get Wi-Fi calling to work.
Today Wi-Fi calling has decided not to work anyway. At times my phone has shown no network coverage but Wi-Fi calling has not started working to compensate. At other times my phone has shown 1 or 2 bars of network coverage but I've still missed phone calls from people and only found out an hour after they called when I received a voicemail notification text.
I've turned my phone off and on twice to try to get it working but to no avail.

I think technical at I.D. mobile need to sort something out.

Dan



Hey @DanT,

Is this issue apparent when testing on multiple WiFi networks also?

Mohammed
Hi Mohammed,
Sorry for the slow response notifications went to my spam.
Yes, I'm still having the same call related problems with my own WiFi networks and other WiFi networks.

Dan
Userlevel 6
Badge +6
Hello @DanT,

Looks like we've been through as much troubleshooting as we can from here so we'll need to access your account to get this raised.

I've PM'ed you with the steps we can take to get this resolved.

Mohammed

Reply