Solved

Roaming charges in France -

  • 20 August 2018
  • 5 replies
  • 282 views

Just arrived to France, I can make phone calls and sent texts but I can't roam , I've checked APN setting , it's ok, I've manually change setting to 3G, my id mobile is set for international roaming I even managed to add the APN manually but I still can't connect to the internet. I'm connected to orange France and I'm using a Sony Xperia xz . Can anyone help with this please. Thanks.
icon

Best answer by Zohar 27 August 2018, 13:50

Thanks for your reply, I managed to fix it, it wasn't the APN setting, my phone has two SIM cards and they can't be on 3G at the same time, so when I changed my id card to 3G and the other SIM card to 2G everything started to work as it should, good to know for other users who has 2 SIM phone, cheers.
View original

5 replies

Userlevel 6
Badge +8

Hi @Colin O 

Did you travel by ferry from France to the UK?  Or at any point were you in Switzerland or a border area of France?

The most common occurrences of any sort of unexpected roaming charges would usually be when people are on ferries. 

Whilst out at sea, you’d no longer be connected to either a UK network or a French network and instead be covered from a satellite network through the ferry.  So you’d no longer be within reach of one of the 50 destinations to which you’d get inclusive roaming in.

 

In other cases.  In the French Alps.  If you’re far out from where mobile coverage might be prevalent.  Then your phone would automatically connect to the strongest network it can reach.  If that happened to be one in Switzerland, then that would cost money to use as Swiss networks aren’t a covered destination for inclusive EU roaming.  The best way around that is to have your phone only manually connecting to a French network (Orange or Bytel) -or- to turn off roaming whilst in such regions.

I’ve returned from a holiday to France and been charged a ‘rest of world roaming’ charge of £5.83. I have only been to France and the UK. Can this be right when I haven’t left the EU?

Userlevel 7
Badge +9
Thanks for your reply, I managed to fix it, it wasn't the APN setting, my phone has two SIM cards and they can't be on 3G at the same time, so when I changed my id card to 3G and the other SIM card to 2G everything started to work as it should, good to know for other users who has 2 SIM phone, cheers.

That's awesome @Zohar,

Thanks for sharing that with us.

We appreciate your solution and will keep it in mind for future. I've marked your comment as the best answer to this topic also.

Mohammed
Thanks for your reply, I managed to fix it, it wasn't the APN setting, my phone has two SIM cards and they can't be on 3G at the same time, so when I changed my id card to 3G and the other SIM card to 2G everything started to work as it should, good to know for other users who has 2 SIM phone, cheers.
Userlevel 7
Badge +9
Hello @Zohar,

I know you mentioned you added the APN manually, have you tried deleting all APN settings and re-adding?

To confirm, Roaming needs to be turned on on the iD App (which it seems it has already been done if you can make calls and texts).

"Data Roaming" needs to also be turned on in the handset settings. Without this, no amount of correctly configured APN settings will matter.

Have you definitely turned on Data Roaming in the handset settings also?

Mohammed

Reply