Question

About phone>Status>My phone number: Unknown

  • 14 December 2019
  • 3 replies
  • 378 views

Migrated old phone number from O2, everything seems to be working okay, but when I go into Settings>System>About phone>Status, it gives “My phone number” as Unknown.  Not a show stopper, but clearly something’s not right.  New phone is a Huawei Y6 (2019), and I’ve re-seated the SIM card and restarted it - no change. 

Jim


3 replies

Userlevel 6
Badge +8

Hi there.

Is this still the case @Jim_Smith?

Does your phone allow you to change the number within the settings at all?  Or are you able to enter your number manually when providing details into your Google Account at all?

Hi Kevin, 

Thanks for your response.  Yes, the situation is still the same.  I can’t find any option to change the setting.  I did look at the Huawei website and that seemed to indicate that the number should appear automatically when the number is migrated - if not contact your provider.  As I said, there doesn’t seem to be any problem using the phone, and of course, my Google Account is set to my number. 

Jim

Userlevel 7
Badge +9

Hello @Jim_Smith,

 

I believe this is a common issue for Android phones where the number does not automatically update. I don’t believe there is a way to manually change this, unfortunately, but should not affect the handset usage in any way nor should it affect the network or the number active on the SIM.

Mohammed

 

Reply