Question

Samsung S10+ WiFi Calling

  • 18 May 2019
  • 9 replies
  • 160 views

Userlevel 1
I'm having trouble getting WiFi Calling working on my S10+. I was previously on Three and had no issues with WiFi Calling with them.

I have tried disabling/reenabling and restarting the phone, and have also reset all network settings to no avail. I have joined iD within the last week and ported my old number across, not sure if this has any impact on WiFi Calling being enabled?

Any help would be appreciated.

Dan

9 replies

Userlevel 6
Badge +6
Hi welcome to ID Community,

Goto settings/wifi and turn wifi off [not wifi-calling] wait a while then turn it back on again, this resolves it for me! [Do not toggle wifi off from the widget menu this only disconnects the wifi]

Check out the below link for more on wifi-calling and the official supported mobile list
https://www.idmobile.co.uk/help-and-advice/wifi-calling

Try turning DATA off, this can confuse some mobiles and cause Wifi to not work as expected.

Alternatively...
Follow these steps if you can't turn on Wi-Fi Calling or make a Wi-Fi call. Wait two minutes before you go from one step to the next.
  1. Go to Settings > Phone > Wi-Fi Calling and make sure that Wi-Fi Calling is on.
  2. Restart your Phone.
  3. Connect to a different Wi-Fi network. Not all Wi-Fi networks work with Wi-Fi Calling.
  4. Turn Wi-Fi Calling off and then on again.
  5. Go to Settings > General > Reset and tap Reset Network Settings.
You should not need to reinstall any software as this is a wifi / network issue.

You could try going to general and update and accept any new carrier settings that are available, new carrier settings are released every few weeks.
Userlevel 1
Hi welcome to ID Community,

Goto settings/wifi and turn wifi off [not wifi-calling] wait a while then turn it back on again, this resolves it for me! [Do not toggle wifi off from the widget menu this only disconnects the wifi]

Check out the below link for more on wifi-calling and the official supported mobile listhttps://www.idmobile.co.uk/help-and-advice/wifi-calling
Try turning DATA off, this can confuse some mobiles and cause Wifi to not work as expected.

Alternatively...
Follow these steps if you can't turn on Wi-Fi Calling or make a Wi-Fi call. Wait two minutes before you go from one step to the next.
  1. Go to Settings > Phone > Wi-Fi Calling and make sure that Wi-Fi Calling is on.
  2. Restart your Phone.
  3. Connect to a different Wi-Fi network. Not all Wi-Fi networks work with Wi-Fi Calling.
  4. Turn Wi-Fi Calling off and then on again.
  5. Go to Settings > General > Reset and tap Reset Network Settings.
You should not need to reinstall any software as this is a wifi / network issue.

You could try going to general and update and accept any new carrier settings that are available, new carrier settings are released every few weeks.


Thanks for the input Terry.

Unfortunately, I think I've tried similar things yesterday with no joy. I've since tested my SIM in a iPhone 7 and WiFi Calling works without issue.

I have a hunch that i need some form of carrier settings to be pushed out to my SIM whilst in the S10 to get it to start working.
Userlevel 6
Badge +6
The ID Mobile team can sort carrier settings update if needed have a word with live chat

Have a look at updating your software on the mobile too, generally this is a long shot but Samsung software possibly could be the culprit here!
Userlevel 1
The ID Mobile team can sort carrier settings update if needed have a word with live chat

Have a look at updating your software on the mobile too, generally this is a long shot but Samsung software possibly could be the culprit here!


Ive spoken with them today and yesterday, but unfortunately they weren't much use. I got directed to a carphone warehouse store...

Its frustrating as it worked fine with my three SIM, and despite being on the supported list it's not working now with iD mobile. If I'm unable to resolve I'll cancel my contract and go back to three, as it's a bit of a deal breaker due to me having poor signal at home.
Userlevel 6
Badge +6
Might be worth trying samsung software update from settings about!!!

otherwise please check video HD Voice is ON. should be enabled but if wifi calling not working try it off.

Samsung Galaxy S10 - Turn Video Call On / Off - HD Voice
  1. From a Home screen, tap the Phone icon (lower-left). ...
  2. Tap the Menu icon (upper-right).
  3. Tap Settings.
  4. Tap the Video Calling switch to turn on or off .
Userlevel 6
Badge +6
  1. Tap Wi-Fi Calling, then select desired option:
  • Wi-Fi Preferred
Should already be selected however if you reset the network settings it might have defaulted to data
Userlevel 1
I don't have the option to select either of the last two options you've mentioned, unfortunately.

As I said, I don't think it's necessarily these that are causing the problem as it worked without issue using a three SIM.
Userlevel 1
Unfortunately despite being marked solved, this isn't the case. The two agents I spoke to just referred me to the website help links I'd already told them I had read.

I'm going to assume with the lack of responses that I'm going to have to figure this one out myself, between me and the XDA community.
Userlevel 6
Badge +6
Hello @dancake,

Sorry to hear the issue isn't still resolved.

Can we just clarify if the phone was purchased directly from us or via Three?
My only guess here is that the firmware on the handset is conflicting here and this is what's causing the issue you're having.

If you purchased the phone from us, we'd direct you to Carphone Warehouse as the phone should have the correct firmware from the get-go to allow this to work on our network.

I've un-marked the answer for you.

Mohammed

Reply