Solved

Wi-Fi Calling and 4G Calling not working

  • 22 January 2020
  • 6 replies
  • 130 views

I bought a Samsung galaxy a3 2017 from eBay a couple of years ago. I've just moved to iD but I had no WIFI Calling or 4g calling option in my settings. 

I then realised that my phone had German firmware. So I flashed it with the latest uk unlocked firmware (BTU).

I now have these options in my settings, so I turned them on. However they don't work. I cannot make or receive wifi calls or use 4g calling. 

Online it looked like there should be a symbol in the notifications to show that Wifi calling and 4g calling are being used but there is nothing, so I must assume that the feature isn't working.

I have spoken to about 10 people on live chat and not one has a clue about it. But I don't think they really understood how Wi-Fi calling worked. They were telling me things that I know aren't correct.

Anybody had a similar issue/have a solution to this? Do I need to put different firmware on my phone?

Thanks. 

icon

Best answer by ReeceG 23 January 2020, 13:46

Hi @Ryan

I have now got Wi-Fi calling working. I reinstalled the firmware and then did a factory reset. 

As for 4g calling, I'll have a play around and see if I can get it to work. I believe both myself and the receiving phone must be VoLTE compatible and be in an area supported by VoLTE.

Thanks. 

View original

6 replies

I have a similar problem. I bought a Samsung galaxy a3 2017 from eBay a couple of years ago. I've just moved to iD but I had no WIFI Calling or 4g calling option in my settings. 

I then realised that my phone had German firmware. So I flashed it with the latest uk unlocked firmware (BTU).

I now have these options in my settings, so I turned them on. However they don't work. I cannot make or receive wifi calls or use 4g calling. 

Online it looked like there should be a symbol in the notifications to show that Wifi calling and 4g calling were being used but there is nothing, so I must assume that the feature isn't working.

 

Userlevel 6
Badge +9

Hi @ReeceG,

I am sorry to hear about your issue with the WiFi calling and 4G calling features. I have merged your latest post with your thread so we can try and help you in one place.


Have you tried to reset the network settings within the phone to see if this helps enable the services on your phone? Also, if you have access to a second phone to test the SIM card inside, this will help us understand if the issue is with the phone itself after the firmware flash.

Another step you can try, in regards to the WiFi calling feature at least, is to connect to another WiFi network as some networks may not allow or fully support WiFi calling.

Ryan

Hi @Ryan

I have now got Wi-Fi calling working. I reinstalled the firmware and then did a factory reset. 

As for 4g calling, I'll have a play around and see if I can get it to work. I believe both myself and the receiving phone must be VoLTE compatible and be in an area supported by VoLTE.

Thanks. 

Userlevel 7
Badge +9

Hello @ReeceG,

Glad to hear you managed to get WiFi Calling working.

 

Have a play with the 4G Calling and let us know.

That’s correct, the correct 4G mast needs to be in the area and the phone needs to be compatible on 4G calling for this to work.

 

When you make a call whilst Mobile data is on, it will either say: VoLTE or the service should remain as LTE/4G.

If it drops down to 3G/H+ or H, then it’s switching to 3G calling only.

 

The reason I say is, I thought my phone wasn’t sending calls over 4G because I couldn’t see VoLTE when calling, but turns out as long as it’s sticking with 4G service when I make a call, that was enough.

 

Mohammed

Thanks @Mohammed ,

I will keep trying.

One quick question, for 4g calling to work does mobile data have to enabled on both devices or will it work even if this is switched off. I read in this one post that even with it switched off it'll work. Wasn't sure if this was correct. 

Thanks. 

Userlevel 7
Badge +9

Hello Reece, from what I’m aware, it needs to be turned on for 4G connection.

Mohammed

 

 

Reply