Solved

Wifi Calling Not Working

  • 12 December 2019
  • 8 replies
  • 153 views

Wifi calling does not work. I don’t get any signal where I live so one of the reasons I signed up with ID is because they said I could get wifi calling. I have a new Samsung A40 which should be compatible.

I have turned on wifi calling in settings and the software is up to date.

When I asked about it on live chat they told me to take it to the Carphone Warehouse. I did this, and they said ID need to activate it for me. I asked ID about this and they said they didn’t do that, and told me to go back to Carphone Warehouse.

 

Seems like I am being passed pillar to post so I am asking here in case any one can give me a solution. I have read a similar thread but I haven’t seen any answers.

 

Hope someone can help.

 

icon

Best answer by Ryan 23 January 2020, 13:55

Hi @RossH,

Thank you for bearing with us here whilst we investigated this issue for you, I have recently replied to you via email too, but I will post the answer here to ensure others can benefit from the investigation too.

Unfortunately we are unable to have the WiFi calling feature working on the device that you have purchased. This is due to the fact that the device has not been purchased from ourselves directly and we can't guarantee that the feature will be compatible with devices purchased elsewhere.

Ryan

View original

8 replies

Userlevel 6
Badge +6

Hello @RossH,

 

If you’re on the latest firmware and WiFi Calling is enabled, it should work when your connection drops below a certain limit.

 

Can you try resetting your network settings for me as this should hopefully resolve the issues here?

 

Mohammed

Hello Mohammed,

I tried that but it still doesn’t work.

Userlevel 5
Badge +6

Hi there @RossH 

 

Two more things to try for us here if you’re still having troubles.

  1. Turn off WiFi calling in your phone.  Turn off your phone and restart your home router. 
    Then once your Wifi is back on.  Turn your phone back on, re-enable WiFi calling and see if things have changed at all there.  

    [Sometimes routers can be difficult with enabling a WiFi calling connection if they’ve not been restarted and had a clear of there cache in quite some time].
     
  2. Try seeing if at a friend/ family members house. if your WiFi calling works on their network at all.  This could indicate a router setting at home is perhaps to strict and not allowing the WiFi calling feature to work in your household.
    If that is the case, through contacting your broadband provider they might be able to tell you how to go about modifying your router settings to help things along here. 

Hi Kevin,

No still not working. It says ‘not registered on network’. Also I’m not sure how I could check at a friend’s house, as they would have a signal there so it would just ring out normally. If I try on flight mode, when I try to call etc it just says turn off flight mode.

Userlevel 6
Badge +6

Hello @RossH,

 

One more thing is checking if there are any updates available and updating to the latest version of Android. Can you check this?

 

Yes the software is up to date.

Userlevel 6
Badge +6

Hi @RossH,

Thank you for this information. We’re going to need to escalate this further in order to understand what is going wrong here.

Please can you send us an email to CommunitySupport@idmobile.co.uk with a link to this thread so we can get started? Alternatively, you can contact us via Facebook or Twitter if that would be easier and more efficient for you?

Ryan

Userlevel 6
Badge +6

Hi @RossH,

Thank you for bearing with us here whilst we investigated this issue for you, I have recently replied to you via email too, but I will post the answer here to ensure others can benefit from the investigation too.

Unfortunately we are unable to have the WiFi calling feature working on the device that you have purchased. This is due to the fact that the device has not been purchased from ourselves directly and we can't guarantee that the feature will be compatible with devices purchased elsewhere.

Ryan

Reply