Question

Bug Report: Can't login to my account using the Edge browser

  • 26 January 2019
  • 8 replies
  • 208 views

Userlevel 1
A similar problem to the previous question a month ago with same header (now closed).

I cannot login to my ID account on Lenovo my laptop running Windows10 and Edge browser, (Microsoft Edge 42.17134.1.0). You can enter the username and password but the {Log in} button does nothing. (There is also no box visible to the left of "Remember me" to tick)

Selecting Lost password link takes you to the lost password webpage, it allows the username to be entered but the {Submit} and {Cancel} buttons achieve nothing.

No problem on a desktop running Windows 8 and IE 11.

Is it the App or my laptop the problem?

H

8 replies

I have exactly the same issue. Cannot login as button does noting. cannot reset PW as button does nothing. PLEASE FIX ASAP
Userlevel 4
Have you tried using a different browser on your laptop to see if it works? Just an idea as I sometimes find that things in 1 browser wont work,yet in other browsers work fine. I use Chrome, and Firefox.
Userlevel 6
Badge +6
Hey @HaroldBinley & @Violets mum,

Can you try a different browser as mentioned above as I believe there was an issue with the Edge browser when accessing the website.

Mohammed
Userlevel 1
Windows10 appears to be the problem. As no issues when using Chrome. H.
Userlevel 1
I have the same problem. I contacted iD months ago and was told Microsoft were working on it 😀 Oh how we laughed!

This problem still exists today I have tried logging in several times over the last few days but cannot login using MS edge browser on Windows 10. I can type in the username and password but when you hit the button to login nothing happens.

I have looked on the community topics and found some reports that state that some people cannot login these reports are upto 10 months old. This problem still exists today I have tried logging in several times over the last few days but cannot login using MS edge browser on Windows 10. I can type in the username and password but when you hit the button to login nothing happens.

Userlevel 6
Badge +6

Hello @Plascoch,

 

It’s something that has already been flagged to the Team and on their lists. 

We’ve not had any movement on this and recommend trying a different browser which should work. 

 

As a current workaround, please use the Chrome/Firefox browser and let us know if you still face issues.

 

Mohammed

Reply