Cannot roam in Greece.

  • 13 July 2019
  • 3 replies

Userlevel 1
Hi, I have just returned from Rhodes Greece, and no matter what I did could not get roaming to Work. Enabled roaming on my account before I went, manually set phone to 3G. Still no good. Thing is I had same problems in Germany, first time I took Android On Xiaomi A1, September last year. On that occasion I edited the APN as suggested and it worked with editing. Thought it would be ok in Greece with those settings advised, but no joy on Rhodes. Any suggestions as I am going to Spain Portugal in September, thanks in advance for any insight people may have experienced

3 replies

Userlevel 4
Badge +6
Hi Johnny55.

You can take a look here for general advice about roaming.

If you are able to connect to the network and calls/ texts work ok, it is highly likely to be the APN, assuming data roaming is switched on on your phone.

It might be worthwhile deleting the existing APN and reset to default. If you then get the option to choose iD Mobile, the correct settings will be applied.
Userlevel 1
Hi Phil, thanks for your input. Yes calls text worked. So yep agree it's APN, done the deletion, still did not work. I know id has problems with picking up 3 masts when out of UK unless you edit. Sadly nothing works in Greece for me, but did in Germany when I manually set up for Id not 3 for APN. Resigned it crap in Greece, hope it works in Spain Portugal. Thanks for your input Phil..
Userlevel 1
If you visit Greece again:

First check you’ve got roaming set to on!

Go into your mobile networks settings and click on automatic network selection.
Then depending on which network your phone has chosen, set your APN.

I would recommend setting your APN settings to these:

For Vodafone Greece:
For Wind Greece:
For Cosmote Greece: internet

If these don’t work, type in as your APN instead.

I hope these resolve your problems with roaming in Greece!

Good luck!