Question

Issue with transferring old number - port-in request can't be submitted


Hi, I’m having issues with transferring my old number. 

I have received the phone and new sim.

First, I tried doing it on the website filling out the form, but since I have not received an obvious transaction number I put my order number in and it said it had submitted successfully. A while later, I receive a text from ID mobile to say there was an issue with processing this request and that the details may be incorrect, so I’m guessing I had the wrong transaction number. I did not receive an invoice or anything with my parcel with a transaction number on.

 

I then registered with the ID mobile app and tried to transfer my old number that way. I initially was able to put in the ID mobile number, PAC code and my old number and each had a green tick next to it, but I received an error message saying one of them was incorrect. Now when I try to do it again, there is a message in the app saying “Sorry, your port-in request can’t be submitted at the moment.”

 

Is anyone able to advise what to do next please? I have transferred my old number to other networks quickly and successfully in the past with no issues. I have double checked all the information is correct (bar from the lack of transaction number).

Thanks


2 replies

Update - I just went to try again in the app and it has let me submit my request now so hopefully it goes through properly this time

Userlevel 5
Badge +4

Hi @Snickerdoodle 

If you are still having issues with porting your number, please let us know here and we will send you a Private Message. Just to advise, all number ports can take from 24-48 hours to complete.

-Mohsin

Reply