Question

NEW SIM NOT WORKING AFTER 2 DAYS

  • 30 July 2019
  • 5 replies
  • 91 views

Userlevel 1
I recently lost my phone and have received a new ID SIM about 5 days ago. I spoke to customer service who have activated the SIM, and they said it will work after one hour! However, after 2 days, it is still not working!! What seems to be the problem? How can you assist?

5 replies

Userlevel 2
Badge +5
Hi @Sailesh,

We are sorry to hear about the issues you have faced with the connection of your SIM Card.

Are you getting signal on the SIM? Are you able to make calls and texts?

If you are not able to call out or don't get any signal, I would advise to try and manually connect to the network.

If the issues continue I would advise that you contact our Live Chat Team HERE and somebody can help.

Kash
Userlevel 1
Hi Kash,

Thank you for your reply.

There is no SIGNAL on the phone and it is saying EMERGENCY ONLY.

I have no idea how to manually connect to the network! That should be for your Team I suppose to do it?

I will try connect to a live Chat Team and see if it works.

Please NOTE that this is NOT yet resolved

Sailesh
Userlevel 2
Badge +5
Hi @Sailesh ,

We are sorry that this is not yet resolved.

If you could contact the Live Chat Team and get back to us if you still experience any issues.

We look forward to your reply so we can get this sorted.

Kash
I have same problem 3 new sim cards ,tried speaking to live chat still no answers fed up now had enough
Userlevel 6
Badge +6
I have same problem 3 new sim cards ,tried speaking to live chat still no answers fed up now had enough

Hello @bobtar66,

Which handset are you using the SIM inside?

It would be great to get an idea on what could be causing this.

Could you also confirm your full postcode for us?

Mohammed

Reply