Not receiving text messages | Join the discussion, ask questions, share advice.
Question

Not receiving text messages


Userlevel 1

Hi, since moving from Talkmobile to iD this week I’ve had problems receiving iMessages / text messages. Sometimes they come through, sometimes they don’t. Particular problem with One-Time security codes.

I’ve restarted phone, checked mobile number is correct, reset network settings but no joy. 

Any advice/help would be appreciated.


9 replies

Userlevel 6
Badge +7

Hi @Fuzzydoodle,

Please could you try the below and let us know how you get on?

 

1)    Turn off iMessage (Settings > Messages)
2)    Restart your phone (by pressing and holding the on/off button)
3)    Tap Settings > Phone > My Number and confirm that it is correct. 
4)    If it is not correct, please enter the correct number
5)    Turn iMessage back to On (Settings > Messages)
6)    Finally, go to Settings > Messages > Send & Receive and see if the correct number is displayed under “Start new conversations from:”. 

 

Kash

Userlevel 1

Hi Kash

Thanks for your advice, I had tried this previously and have again but it doesn’t make any difference. 

Any further options would be gratefully received?

Userlevel 8
Badge +5

Okay @Fuzzydoodle, Talkmobile use Vodafone’s network.

Unfortunately, this forum has numerous posts from people who’ve had trouble after porting numbers from the Vodafone infrastructure.

I suggest you TURN OFF iMessage for several days, then try again.

What mobile number is shown when you look at:
    Settings > Apple ID > Name, Phone Numbers, Email > CONTACTABLE AT

What mobile number is displayed in:
    Settings > Messages > Send & Receive - “Start new conversations from:”

 

Userlevel 1

Hi

I’ve looked at both the sections you were to and both say the correct number, although my number is displayed twice under Contactable At, once with iMessage and FaceTime and once separately.

Userlevel 8
Badge +5

Okay @Fuzzydoodle, seems odd that your correct number is displayed twice under:

    Settings > Apple ID > Name, Phone Numbers, Email > CONTACTABLE AT

Have you signed-in to your online iCloud account and Apple account to check what devices and mobile numbers are registered in these accounts?

Perhaps the same mobile number is registered against two different iPhone devices for some reason.

Anyway, good luck

 

 

Userlevel 1

Thanks again, all checked on iCloud and Apple account and it’s setup as it should be. No problem prior to switching from Talkmobile to iD!!!

Userlevel 8
Badge +5

Thanks @Fuzzydoodle, I’d suggest TURNING OFF iMessage and FaceTime for several days in that case - then try again. 

Userlevel 8
Badge +5

Thanks again, all checked on iCloud and Apple account and it’s setup as it should be. No problem prior to switching from Talkmobile to iD!!!

On my iPhone, my mobile number appears just once, with “iMessage & FaceTime number” beneath my mobile number in:

    Settings > Apple ID > Name, Phone Numbers, Email > CONTACTABLE AT

You could try removing the number NOT linked as “iMessage & FaceTime number”.

It seems odd there’s no email address shown with “Apple ID” under “CONTACTABLE AT”.
Apple iMessage won’t work unless you’ve signed-in with your Apple ID.

You might need to contact Apple support (0800 048 0408) for assistance, and also ask iD to look at your iD network account. The latter is likely to be a ‘technical’ request, which will get routed to three - sadly a long-winded process.

 

Userlevel 1

Thanks again, sorry I wasn’t very clear. There is an email address under CONTACTABLE AT, I was just focusing on the mobile numbers. 

I’ll give Apple support a try.

Reply


Why iD Mobile?