Question

SIM Card Not Inserted error on A40

  • 26 May 2020
  • 5 replies
  • 53 views

I bought a new A40 at the beginning of March, along with a new IDMobile SIM.

The phone worked fine for several weeks, but now regularly displays the error “SIM Card not inserted”, and I cannot make calls.

Restarting the phone seems to fix it, but it often recurs  - usually at least once a day.

I have taken the SIM out, made sure it’s clean and unblemished, and re-fitted it carefully. The problem recurs.

I have put the SIM in another phone, and it works flawlessly in the other phone.

The A40 has the latest version of Android installed.

So it looks like it’s a physical fault with my phone.

Please advise as to what solution is available to me.

 

 


5 replies

Userlevel 3
Badge +5

Hi @hlavery 

Sorry to hear this. 

I have sent you a direct message with more information. 

Regards

Aklima 

I'm having the exact same problem with my A40 sim card not inserted, unable to make or receive calls, any help would be great

Userlevel 4
Badge +2

Hi @Iankelsey2 

Welcome to iD Community.

Can you please check the APN settings are correct , you can do this by clicking on this  page.

Let us know if it worked.

Thanks, 

Pearl

My son has been having exactly the same issue with his a40 since I got it for him, unfortunately due to undergoing treatment for cancer I've been too poorly to do anything about it before now other than get him a replacement sim which did not fix the issue. 

Userlevel 7
Badge +9

Hello @DaveonMako,

Sorry to hear that, I do hope you’re keeping well.

Did you activate the replacement SIM on https://www.idmobile.co.uk/help-and-advice/your-sim-card

Additionally, is the SIM card working in other devices?

It sounds like it could be a handset fault but ensuring that the SIM is activated, take out the SIM card and clean it.

If it’s still not working, is it possible to visit a Carphone Warehouse store so the Team can look into this as the handset may be faulty.

 

Mohammed

Reply