Solved

Why doesn't the voicemail icon show when I have new messages?

  • 16 March 2020
  • 6 replies
  • 103 views

When I was with other networks, whenever I received voicemail I was notified by a voicemail icon in the notification bar, and when I selected that icon my phone would call the voicemail number. Now with iD Mobile, the voicemail notification is just an ordinary SMS message. How can I set it up to be an icon like the other networks?

icon

Best answer by klint 22 June 2020, 14:52

Thanks, and sorry for the delayed reply. The fix was to go through the voice menu after dialling the voicemail number and choosing the right setting. So the setting is related to your voicemail system, not the handset.

 

View original

6 replies

Userlevel 5
Badge +7

Hi @klint 

From what I know, the notification should work the same way with ourselves as it would with any other network.

Did you port a number over to us from another provider?  

What phone are you using?  

Thanks for replying, Kevin. I did port my number, from GiffGaff (and when I joined GiffGaff, I had ported my number from another network). When I was with GiffGaff, I was given a choice of notification style, as shown here: https://community.giffgaff.com/d/21518570-voicemail-notifications/2 . I chose the “on-screen notifications”, not SMS. How can I do this with iD Mobile? My phone is a Motorola G7 Plus.

Userlevel 6
Badge +9

Hi @klint,

You may need to change the voicemail settings within the phone in order for this to work as your phone may still be holding onto the settings used by Giffgaff, especially if the phone was used with the Giffgaff SIM at one time. Here is a link to another post which has some information on setting up your voicemail from scratch.

We have a dedicated voicemail page which also has some useful information: Link. Please let us know how you get on.

Ryan

Thanks, and sorry for the delayed reply. The fix was to go through the voice menu after dialling the voicemail number and choosing the right setting. So the setting is related to your voicemail system, not the handset.

 

Thanks, and sorry for the delayed reply. The fix was to go through the voice menu after dialling the voicemail number and choosing the right setting. So the setting is related to your voicemail system, not the handset.

 

@klint , what setting did you find?  I’ve been through all the menu options I can find and all I can find is how to turn the SMS notification on or off.  I still don’t get the proper status bar notification icon.  It’s driving me nuts.

Thanks, and sorry for the delayed reply. The fix was to go through the voice menu after dialling the voicemail number and choosing the right setting. So the setting is related to your voicemail system, not the handset.

 

@klint , what setting did you find?  I’ve been through all the menu options I can find and all I can find is how to turn the SMS notification on or off.  I still don’t get the proper status bar notification icon.  It’s driving me nuts.

I’m sorry, I didn’t make a note of the setting at the time I had changed it and now can’t remember which option it was.

Reply