Solved

Wrong number still showing in messages after port?


Userlevel 1
I have successfully ported in my old number to my ID mobile sim but recently it has stated to show my temporary ID mobile number when I send a text to anyone.

Why is this?
icon

Best answer by Mohammed 28 May 2018, 15:01

Hello @Black-kite-13,



Welcome to the iD Community!



Is this an iPhone by any chance?

The culprit for this would be iMessage.



What happens sometimes is when you've ported your number, iMessage doesn't update to the new number and needs to be done manually.



Can you try the following;



1) Try turning off iMessage (Settings > Messages)

2) then restart your phone (by pressing and holding the on/off button)

3) tap Settings > Phone > My Number and confirm that it is correct.

4) If it is not correct, please enter the correct number)

5) then turn iMessage back to On (Settings > Messages)

6) go to Settings > Messages > Send & Receive and see if the correct number is displayed under “Start new conversations from:"



This should fix the issue you're facing (if it's an iPhone you're using)



Mohammed



EDIT: Duplicate topics merged to clean up the community.
View original

11 replies

Userlevel 7
Badge +9
Hello @Black-kite-13,

Welcome to the iD Community!

Is this an iPhone by any chance?
The culprit for this would be iMessage.

What happens sometimes is when you've ported your number, iMessage doesn't update to the new number and needs to be done manually.

Can you try the following;

1) Try turning off iMessage (Settings > Messages)
2) then restart your phone (by pressing and holding the on/off button)
3) tap Settings > Phone > My Number and confirm that it is correct.
4) If it is not correct, please enter the correct number)
5) then turn iMessage back to On (Settings > Messages)
6) go to Settings > Messages > Send & Receive and see if the correct number is displayed under “Start new conversations from:"

This should fix the issue you're facing (if it's an iPhone you're using)

Mohammed

EDIT: Duplicate topics merged to clean up the community.
Userlevel 1
Hi Mohammed, yes it is an iPhone, your solution has worked a treat and solved the problem.

Thanks for the full and clear answer, hopefully will be helpful to others.

Best Regards

Black-kite-13
Userlevel 7
Badge +9
Hi Mohammed, yes it is an iPhone, your solution has worked a treat and solved the problem.

Thanks for the full and clear answer, hopefully will be helpful to others.

Best Regards

Black-kite-13


That's great @Black-kite-13

I'm glad to hear this has resolved the issue!

Mohammed
Userlevel 1
I have sent my pac code over via the app. My phone number has now changed but when i text it is still under the old number. Any ideas ?
Userlevel 7
Badge +9
Hello @Steved,

Is this an iPhone by any chance?

Can you try:

1) Try turning off iMessage (Settings > Messages)
2) then restart your phone (by pressing and holding the on/off button)
3) tap Settings > Phone > My Number and confirm that it is correct.
4) If it is not correct, please enter the correct number)
5) then turn iMessage back to On (Settings > Messages)
6) go to Settings > Messages > Send & Receive and see if the correct number is displayed under “Start new conversations from:”


Let me know if this works.

Mohammed
Userlevel 1
All working 👍
Userlevel 7
Badge +9
All working 👍

Awesome!

Glad to hear @Steved.

Thanks for confirming this. 😄

My wife phone has ported her old number over to ID mobile it is a android Moto g 7. Do you know how to fix this, I've tried to Google the answer but not having much luck thanks

Userlevel 7
Badge +10

Hi there @Mark2020 

Could you have her turn the phone off, remove the SIM.

Then turn the phone on (without SIM) and leave it for about 4-5 mins or so.

Then turn off, re-insert the SIM, and turn back on.

That should hopefully cause the phone to refresh the number in the Android settings.

Let us know how you get on.

Thanks for the help it was the phone in the end 3g stop working. Bought a new phone and worked straight away ☺️. All is working great now

Userlevel 7
Badge +10

Great to hear things are working at least now @Mark2020

If you need us again just get in touch here.

Merry Christmas.

Reply