Unable to switch off call forwarding on iphone | Join the discussion, ask questions, share advice.
Question

Unable to switch off call forwarding on iphone


The call forwarding on iphone does not load. Tried Network reset, taken SIM card out and fit back, tried SIM card in another phone to switch off still no joy. Spoken to Apple support who asked me to enter ##002# and ID mobile serever still cannot be seen and I get error message. I have been told that this is ID Mobile setting and they are the only ones who can reset it and thne stop call forwarding. I have proven the issue is not the phone but the ID SIM.


19 replies

Userlevel 7
Badge +10

@Sam1001

In most cases this should just be a setting within your phone itself, and not particularly be locked behind any sort of network specific options on ID Mobile.

  1. On the Settings screen, tap Phone and then tap Call Forwarding.
  2. Toggle the button to turn off Call Forwarding.

It may take a while for the toggle button to show - please be patient!!!

Just tried it on my iPhone and this method works - if there is an issue with the SIM card then you may need to get in touch with support 

send an email to the support team as below

In order they can access your iD account please email with your Community Username, Full Name, Full Address, iD Mobile Number and Date of Birth and they well have this sorted. They usually reply and have many issues sorted within 24hrs.

Hi Terry, I have tried the steps you suggested and it just tries to load call forward , I have waited 5mins with load sign. I have another iPhone with Vodaphone sim and it opens toggle button up instantly to allow  on or off.

 

it could be a problem with SIM but Apple support think it needs to be done by ID end .

Userlevel 7
Badge +10

 @Sam1001 interesting information, thanks, please get in touch with ID support email as suggested earlier they will be able to help further with the faulty SIM.

Userlevel 7
Badge +10

@Sam1001 update to your issue

Turn on data, try again when you see the spinning wheel wait a while, if it still spinning after 30 seconds, go back to the previous phone menu then go forward to the caller ID menu again….

 

Mine does the same if you go back to the previous menu and then forward it works - it’s a network issue!

Userlevel 6
Badge +10

Hi @Sam1001 Did you manage to get it sorted at all?

 

If you put the iD SIM into another phone, does it allow you to turn off the forwarding there?

Hi Kevin, the issue followed the ID SIM card and even when fitted into another phone the spinning  wheel was being shown when call forwarding was selected.

ii emailed ID mobile to reset at their end. Did not get a reply but when I tried again after a day it worked ok. I am not sure if this was reset or it was ia fault at their end  that has been fixed. I can select call forwarding and it loads. I am not going to switch ON until I can speak o ID Data technical team.

Userlevel 7
Badge +10

@Sam1001 

Call Forwarding short codes
from your phones dial keypad type one of the following:

Turn on call forwarding to a number (prevents calls to your number)
*21*PhoneNumber#    

Turn off forwarding
##21#

Call Forwarding Status
*#21#
 

This is also happening to me and is becoming a royal pain

 

cant seem to get hold of any support…???

Userlevel 8
Badge +9

Hello @Seanchambers,

 

Have you tried the above steps?

 

Mohammed

I have and they don’t work

Userlevel 8
Badge +9

Hello @Seanchambers,

I’ve PMed you with how we can look into this further.

 

Mohammed

 

Userlevel 1

Hi

I have just joinediD. I have not changed any settings on my phone but if I do not answer the phone it does not register the number and all calls are forwarded to voicemail. This did not happen with my old phone. Customer services say it is nothing to do with iD. I have tried the fix suggested here - ##21# and the screen showed a message saying call forwarding had been turned off but when I go to call settings it still says call forwarding is on for busy, unanswered and unreachable and when I try to turn it off there I get a message saying my operator does not support disabling call forwarding for any of these. Help!

Userlevel 1

I have posted about this on another thread but this seems more appropriate. I have a Nokia 1 which says my operator doesn’t support disabling call forwarding when the phone is busy or unanswered or unavailable . I have tried the tip above ##21# to try and turn it off but it has not worked. Customer services say this is a Nokia problem but Nokia says it is not.  My calls are forwarded to voicemail It is a real nuisance to have ring voicemail to see who has rung me rather than seeing the numbers in the call log

Userlevel 7
Badge +10

Hi @jan68,

I’m sorry to hear about that issue. When you mention turning the forwarding off within the settings of your phone rather than by dialling the number, are you referring to the below method? 

  1. Press the phone icon.
  2. Press the menu icon.
  3. Press Settings.
  4. Press Calls.
  5. Press Call forwarding.
  6. Press the required divert type.
  7. Press TURN OFF

If so, are you able to try and turn the Voicemail service off within your iD Mobile account and then try the above again a few minutes later? To turn off voicemail, simply log in to your iD app or log in to my account area and select 'services', then toggle voicemail 'off'.

Ryan

Userlevel 1

Thanks for that. I realise that originally I didn’t explain the problem but I thought I had when you offered to help. I do not want to turn off voicemail. I want missed calls to be registered in the call log. At present only outgoing calls are registered in the log. Missed calls go straight to voicemail without being recorded in the log. I have had 8 calls from the same number which has been identified elsewhere. All these calls have gone to voicemail - though I have never heard the phone ringing and sometimes I have been near the phone. I have to ring voicemail only to find it is this scam number with no message. A separate problem is that I have blocked this number on my Nokia app but it has not stopped it. I can’t find anywhere on the iD app to block it .

So I would like outgoing calls in my log and I would like to be able to block scam calls.

Thanks

Userlevel 1

To add to this. I am here with my phone. It did not ring but it pinged to say I had a voicemail message. I do not understand how I can get a voicemail without the phone first ringing. I have checked that phone ring is on. The message says I was rung at 13.38 when I was sitting with the phone next to me. There is no call in the call log. The number is the same one every time and this is the number I have tried to block. If it helps it is 01282707170. I have googled this number and there are numerous reports that it is spam.

I see in my previous message that I have made a mistake, I want incoming calls to be listed in the call log but I really want to stop this number ringing me twice a day and leaving no message

Userlevel 1

Please help me block this number. Same number gone to voicemail at 18.02

Userlevel 6
Badge +10

Hi there @jan68 

Does your Nokia phone let you select the phone number from your call log and then give you further options (such as add it to your contacts/ block the number etc)?

It’s usually directly within a phone itself that you would block a phone number, this isn’t something we can do from our side nor within the iD Mobile App.

 

Are you having problems with any other number going straight to voicemail without your phone physically ringing? 

If so, you may need to check if you have Voicemail turned on or any sort of Call Divert settings on in your phone which is causing you to miss calls.

Userlevel 1

Thanks. I’ve blocked the number on my handset. I am only having problems with this number and I’ve done some research and found that there is an app which lets senders bypass the call and go straight to voicemail. The phone never rings and since other research shows that this is a nuisance number I guess there is nothing I can do. I’ve reported the number to the ICO.

Thanks for your help

Reply


Why iD Mobile?