browsing issues, ping

  • 17 October 2020
  • 7 replies



I’m a new user of unlimited plan

first two days (I think) all was ok, then started issues with browsing

all stream services like netflix, youtube or spotify are working ok - probably because they buffer

but when I’m using browser (safari, chrome, opera, firefox) there is an issue - about 70% of

websites not loading, I need to reload websites many times to load their content

I’m using Alcatel e70 but to be sure I also used my Xperia XA2 as a hotspot and

situation is the sam

this doesn’t depend on transfers shown by speed test services - once they are 15-20Mbits

and once 1-2Mbits (probably because of day time or weather) 


I’m not sure what is the reason
tried ping and ping time is very unstable from about 50ms to over 1second


any ideas?

7 replies

Userlevel 5

Update browser. Clear cache of browser.

Insert sim card to sim1 slot.

Petershaha80 - I did that, my mac os is updated, all four browsers I used are updated as well

my mifi has only one SIM slot (oh its firmware is also updated), in my Xperia mobile phone

I put SIM into sim1 slot of course

I can’t see hardware problems, all depends on network only

Userlevel 6
Badge +8

Hi there @jacekma80 

Is it a data-only SIM you’re using?

Do you notice if you have these problems when the SIM is in a phone itself?  Or is it only your MAC you’ve noticed this on (when using though the hotspot)?


hi @Kevin 

ye it is 18£ monthly contract with unlimited data

I use it with Alcatel E70 but when I put it to my Xperia XA2 and set it as hotspot it was the same
also when when I tried in Xperia’s chrome browser the same


all streaming services working well - in mac, in mobile phone connected via wifi, in google chromcast
problems are in browsers
all the time I need to fill forms on websites many times till finally data are submitted (this is nightmare a specially it is a part of my job)
I need again and again refresh page and fill data again - for example I still can’t update my address in my iD Mobile account because can’t submit data :(

earlier with my mac and mobile all was ok with other broadbands and wifis 

troubles started when I switch to your network

Userlevel 5
Badge +7

Hi @jacekma80,


Have you an ad blocker enabled? Are Pop ups enabled?


If you could enable Pop-ups and disable an ad-blocker if you have one and let us know how you get on, that would be great.





hi @Will 


I’m IT guy :)

I tried it. I use safari as default browser with ad blocker (but disabled it) and three other browser

It didn’t help in fact.

look how pings look - some packets are lost, some took so long time - it is not normal.


Userlevel 5
Badge +7

Thanks for that @jacekma80,


Have you any examples of which specific websites that are having issues loading?