Solved

Can’t send text messages

  • 20 January 2021
  • 7 replies
  • 25 views

Hi, I have recently joined iD Mobile and can’t send text messages. It’s an iPhone 12 mini.  I have tried various things as suggested on threads where other people have had this issue ( such as checking network coverage, turning off imessage, restarting etc) still no luck. 
One text actually went through and was delivered 3 times despite only being sent once. And a while afterwards I got a message saying it was not sent! 
Can you help please?

icon

Best answer by Michelle 2 February 2021, 11:34

Hi @becsicle 

 

Thank you for the update, we are pleased this issue has been resolved.

 

 

View original

7 replies

Userlevel 4
Badge +3

Hi @becsicle 

We are sorry to hear this. We can see it has been 2 days since you posted this message, are you still having issues with sending text messages?

-Mohsin

Thanks Mohsin.

 Yes, I’m still having trouble with it. One recipient receives the message 3 times even though I get ‘message failed to send’.

 Other recipients aren’t receiving anything and I get a message failure.

 

Userlevel 7
Badge +9

Hi @becsicle,

Did you port your number over to us when you got the phone?

Also, you mention that you have tried some settings, can you give the below another go to see if it helps?
 

1)    Turn off iMessage (Settings > Messages)
2)    Restart your phone (by pressing and holding the on/off button)
3)    Tap Settings > Phone > My Number and confirm that it is correct. 
4)    If it is not correct, please enter the correct number
5)    Turn iMessage back to On (Settings > Messages)
6)    Finally, go to Settings > Messages > Send & Receive and see if the correct number is displayed under “Start new conversations from:”. 

Finally, I’d try resetting the network settings. Please go to Settings > General > Reset > Reset Network Settings

Please let us know how it goes.

Ryan

Thanks Ryan.

 Yes I’d tried the first process a few times. 
i tried the network reset just now but it’s still not working. 
yes I did port my number.

 What else do you suggest...?

 Thank you!

Userlevel 7
Badge +9

Hello @becsicle,

The issue is down to iMessage but it’s odd that this hasn’t triggered the change.

Please can you try powering down your handset and removing the SIM for 10 minutes then restarting?

 

If this persists, try resetting network settings and then updating the iMessage number again.

 

Mohammed

Thanks.

 I’ve solved it now. The original number (pre-port) was still listed, though not selected, within the setting-imessage-send and receive section. Once I’d worked out how to delete it (press and hold, rather than swiping as I’d been trying), it all worked fine. Hope this helps anyone else with the same problem.

 

 Thanks again

Userlevel 4
Badge +7

Hi @becsicle 

 

Thank you for the update, we are pleased this issue has been resolved.

 

 

Reply