Question

No data connection

  • 22 December 2018
  • 5 replies
  • 3058 views

Userlevel 1
I can make calls and text but can't access the internet, but airplane mode is off, data roaming is on, and I've full data allowance on my account. It's a new id account - what's gone wrong?

5 replies

Userlevel 6
Badge +6
I can make calls and text but can't access the internet, but airplane mode is off, data roaming is on, and I've full data allowance on my account. It's a new id account - what's gone wrong?

Hello @Krankenstein,

Data Roaming is if you are abroad and want to use data. Are you currently out of the UK?

Mobile Data is the switch you will need to make sure is turned on.

If you are in the UK, can you confirm which handset you're using?

You'll need to make sure you're using the correct Access Point Name (APN) Settings found here:
https://www.idmobile.co.uk/help-and-advice/get-your-settings

Mohammed
Userlevel 1
Hi Mohammed, I'm in UK. Mobile data is on. The phone is unlocked galaxy note 9. I've changed the apn settings but there's no change - I still can't access the internet.
Userlevel 6
Badge +6
Hello @Krankenstein,

Make sure any APN settings you currently have are deleted, also delete the current iD Settings you have.

Then, add a fresh new APN setting with the iD APN settings above. (Deleting all APN's and adding a new one triggers a reset on the network which works in most cases).

If that doesn't work, you can try going into resetting to the network defaults via the APN settings menu.

Failing that, try using the SIM in a different phone and let us know how you get on.

It's very odd if the APN settings don't resolve the data connection issue as calls & texts seem to be okay.

Mohammed
Userlevel 6
Badge +7
@Krankenstein this might shed some light on your issue...

After doing some research in to this issue, you might be glad or not to here this solution could be beneficial to you and others, after the last update from Samsung it seems you are not alone.
Stems from an update concerning wifi and data back in August 2018.

Disable VoLTE Calls in the Settings -> Connections -> Mobile Networks menu.
this fixed data for 80% of people that don't use VoLTE service.

If that doesn't resolve your issue try using 3g instead of 4g. Not ideal but fixed it for 100% of people.

Alternatively update your software from Samsung: they might have fixed this issue!
  1. Tap Settings.
  2. Select Software update.
  3. Tap the option to Download updates manually.
  4. Follow the rest of the onscreen instructions to instigate update file downloading and installation process.
If not, you can take a look at our firmware database and download the latest firmware for your country.
Userlevel 6
Badge +7
@Krankenstein forgot to mention wifi is known to interfere with DATA so turn wifi OFF even if not connected! Some mobiles have settings to use wifi over data in poor reception areas and fall back settings for wifi to use data when not connected, these essentially interfere with each other, best have these extra features disabled.

Reply