No signal at place of work

  • 29 June 2020
  • 7 replies

I have new, recent problem at two work (NHS) locations and I can now only make emergency calls.  I don’t receive any calls, texts or emails, which is problematic.  How can this be improved?

7 replies

Userlevel 7
Badge +9

Hi @CarolineH,

I am sorry to hear about that! Please can you confirm the postcodes of where the issues are happening so we can check out the coverage levels of those areas?


Hello - thanks for any help you can provide.  KT8 9LJ and KT7 0EB

Userlevel 6
Badge +9

Hi there @CarolineH 

Taking a look at the KT8 9LJ postcode first of all.  Some work was carried out recently (June 30th) to address some issues that had been flagged that could be affecting things locally.

Currently speaking we’re still awaiting for an update on the network availability there.  We’d imagine Three (who’s network we provide our service through) have scheduled to get an engineer back down there to follow up on any recent work.


The KT7 0EB postcode doesn’t show that there’s been any issued at all in the past couple of months there.

Do you notice things improve at all when you’re outside the buildings?


I used to work within a hospital myself and the building was notoriously bad for coverage.  It tended to help to use the public WiFi there and turn “Wi-Fi calling” on within my iPhone (at the time) to get a boost of coverage indoors via WiFi at least.  

Hi - I’m currently self-isolating so not at work for a week and haven’t been able to test anything.  I used to have to walk a fair distance from either building, ie 30+m before getting signal.  I don’t know how to turn on Wi-Fi calling (Samsung).  Where do I find it and does that boost signal for incoming calls?

Userlevel 7
Badge +9

Hello @CarolineH,


Which Samsung are you currently using?


WiFi Calling will help when service is low as it’ll use WiFi to make calls.



Galaxy A3 (2017).  I need to receive, as well as to make, calls.  Will Wi-Fi calling help with that?

Userlevel 4
Badge +6

Hi @CarolineH, indeed it will, so long as you have access to a Wi-Fi network, of course. On your Samsung A3, can you please try the following? From the main screen, open the Phone, and tap the three vertical dots in the top-right corner. Tap Settings and then scroll down to Wi-Fi Calling and ensure this is toggled to ON.

Please note: if you didn’t buy the phone from us directly, we cannot guarantee compatibility. Let us know how you get on.


Thank you,