not registered to any network

  • 30 June 2020
  • 5 replies

Suddenly phone not sending or receiving calls and texts. says not registered to any network. Have turned off and on have taken sim out and put in again rest of family phones ok no problem.

5 replies

Userlevel 6
Badge +9

Hi @CRobinson,

I am sorry to hear that! Are the rest of your family members also on iD Mobile? 

On your own phone, can you head to Settings and then to the Mobile Networks section. Once there, please try to do a manual network search; the method for this depends on the make and model of your phone but it’ll likely be under “Network Operators”.

If that doesn’t help then please pop your SIM card into another phone and let us know if this makes any difference to the issue.


 Thanks for you reply. Have tried to use it in an old phone now still no luck. Have done a search for network comes up with an error and to try again later. All my family are with ID and have no problems.

Userlevel 6
Badge +8

No no, don’t post any personal details on this thread itself.

We’ve just “followed you” which should hopefully enable you to reply back to the message we’ve sent.  Please let us know by reply here if it’s still not letting you reply to the message there.

Userlevel 6
Badge +9

 Hi @CRobinson,

Thanks for trying that for us. We will have someone message you as soon as possible so we can look into this issue further for you.


Hi do you want me to verify my details over this public forum as I can't reply on dm. Carly