Solved

No Network

  • 12 March 2021
  • 4 replies
  • 67 views

I am having problems with the network coverage, as it looks like a few people have not so Long ago. This is both network and data. 

 

Can I just point out, that the reason for saying this is because, up until this point, it has been working perfectly fine. Just before I'm asked to check coverage.

 

I've been a customer since November and had no problems up until the last couple of days.

 

I really don't know what the problem is, I just want to get it fixed as soon as possible please. This is not the best time to not be able to contact people, I don't really want to be paying for something I don't have access to our continue to go out hunting for the nearest hotspot so that I can.

 

I'd really appreciate some help please. Thank you!

icon

Best answer by Mohammed 15 March 2021, 18:51

Hello @Dzintra,

I’m sorry to hear you’re having coverage issues here.

Please can you start by confirming the full postcode for us to check the masts in your area?

 

Based on what you described, it sounds like to me this is an issue that’s temporary since it was fine since November.

Mohammed

View original

This topic has been closed for comments

4 replies

Userlevel 7
Badge +9

Hello @Dzintra,

I’m sorry to hear you’re having coverage issues here.

Please can you start by confirming the full postcode for us to check the masts in your area?

 

Based on what you described, it sounds like to me this is an issue that’s temporary since it was fine since November.

Mohammed

Hi again Mohammed,

 

I knew I had mentioned testing my network somewhere, just got the messages mixed up.

 

I can confirm the postcode in an email.

 

As I said in my previous email, I have turned my phone on and off multiple times. There are two phones that are a part of your network experiencing the same issues. It's still happening on and off throughout the day at different times.

 

This will be have been going on almost a week now.

 

As I said in the email, from what I understand ID is connected to use Three's network.

 

They have been prompt in posting that there have been coverage issues. I checked. As ID uses Three's network, I would imagine that is more to do with the issues experienced.

 

Three had also made posts about appropriate settings while experiencing this issue. You might want to have a look.

 

I tested my coverage using the ID checker and as far as that, and my experience up until this point is concerned, these issues shouldn't be occuring regarding the network.

 

We are still in a pandemic, not completely clear just yet, and I have just lost my uncle. It's difficult enough to maneuver contact with the changes to daily life currently, Without this extra problem on top. I'd really appreciate this being resolved as quickly as possible.

I don't consider this issue resolved. And my review on trust pilot will stay as is, until it is.

 

 

 

 

Userlevel 6
Badge +4

Hi @Dzintra 

We will send you a Private Message so we can look into the coverage in your area. To view the message sent.  Simply click on your profile icon in the top right, then go to your private messages.

-Mohsin