Question

5g not being used despite being in 5g coverage area


I would like to speak to a member of technical support ref my new Google pixel 5 5g not connecting to 5g. It's enabled and set to preferred carrier option, my phone software is up to date, I have tried resetting the phone. I have rebooted the phone whilst in 5g coverage and still nothing.

Is there a way to contact ID rather than putting messages on a forum? 

 

Thanks

 

 

 

 

 


12 replies

Userlevel 5
Badge +1

What exactly does the coverage map show for your area?

http://www.three.co.uk/Discover/Network/Coverage

 

Have you ever had 5G signal?

This is the coverage map for the surrounding are, no matter where I go in the dark blue areas I never get 5g. I have never had 5g as it's a new contract with ID. Is there an issue with my contract, phone, or something else? Seems very odd nomatter where I go it never registers 5g? 

Userlevel 5
Badge +1

Maybe try doing a network reset?

On my Samsung Ultra 5G device it’s here:

Settings > General management > Reset > Reset Network settings

 

however, ff you have never had 5G access then it could possibly be account related.

A member of staff will need to take a look and confirm that 5G is enabled on your account.

 

You can ask a live agent here: https://www.idmobile.co.uk/live-chat

 

Or, you can sit back and wait for one of the forum staff members to respond to your thread.

(Which is what I would do)

 

Good Luck! 🤞 

Similar issue. I contacted iD chat and was told iD are a 3g and 4g network. Then I was informed that 5g is only available for voice calling in my area? 

Userlevel 5
Badge +1

Well thats a contradictory sentence if ever I read one!

iD are a 3g and 4g network… 5g is only available for voice calling

😂🤣

 

 

 

Userlevel 5
Badge +1

I didn’t doubt what you said for a minute and I wasn’t laughing at you. 🙂

Userlevel 5
Badge +1

First check that you have enabled 5G on your device…

 

On a Samsung you can do that here:

Settings > Connections > Mobile networks > Network mode

 

 

If 5G is definitely enabled on the device then try a network reset.

On my Samsung Ultra 5G device it’s here:

Settings > General management > Reset > Reset Network settings

 

Might also be worth checking if there are any known issues in the area you are having issues:

http://www.three.co.uk/support/network_and_coverage/network_support

 

If it still doesn’t work then your account is either not provisioned for use with 5G or there is no 5G coverage at your location regardless if the coverage map stays there is.

Hopefully a member of customer services will pick up soon. Thanks for all the community help so far but still not clear as to why I can't access 5G despite everything being OK. 

Userlevel 3
Badge +7

Hi @Carlos1981 ,

Is this an upgrade or a new contract?

Could you please try resetting your network settings and restart the handset?

 

Kash

Hi @Carlos1981 ,

Is this an upgrade or a new contract?

Could you please try resetting your network settings and restart the handset?

 

Kash

Its a new contract. I have reset everything numerous times and still no 5g available despite being outside in a deep red coverage area. 

Userlevel 4
Badge +6

Hi @Carlos1981@Michael654,

I’ve now sent Private Messages to your Community accounts, so we can discuss your issue further. To access your messages, click your profile picture in the top right hand corner and then click ‘Private Messages’. Alternatively, if you are currently logged in, you can use the following link: https://community.idmobile.co.uk/inbox/overview

We’ll see you there.

 

Thank you,

Rory

 

Reply