Solved

Mobile data not working [Roaming]

  • 17 May 2018
  • 9 replies
  • 15930 views

Userlevel 1
I’m having problems whilst in Spain with mobile data. Although it is switched on both on my phone and in the app, unless Wi-Fi is available it tells me it is disconnected. I don’t know how to make it work so any suggestions will be great fully received.
icon

Best answer by Mohammed 21 May 2018, 10:53

Hi @Eildon,

Are you having any issues with making calls/texts when abroad?

What network are you showing you're connected to?

One key thing I often advise users to try is to delete all of the current APN settings.
Then add fresh new ones with the ones outlined in the linked topic.
This can often reset you on the network and seems to work most of the time.

Have you tried manually connecting to a network?

Mohammed
View original

9 replies

Userlevel 1
Hi,
I've experienced a problem like this too.
In my case the APN settings weren't quite correct.
In the very long post here scroll down until you find the section marked Configuring the correct Access Point Name (APN) settings.

I hope this helps.
Userlevel 1
Hi, thanks for taking the time to reply. I have done all of the above, handset turned on to roaming, turned on in app too. I changed apn settings and it still says mobile data disconnected. I guess I’ll just have to search for free Wi-fi areas.
Userlevel 1
Hi, thank you responding. I have already checked and changed apn settings to no avail. I. Not sure what I do next though but will keep persevering. You never know, I might make it before I return home.
Userlevel 6
Badge +6
Hi, thanks for taking the time to reply. I have done all of the above, handset turned on to roaming, turned on in app too. I changed apn settings and it still says mobile data disconnected. I guess I’ll just have to search for free Wi-fi areas.

Hey @Eildon,

Where are you currently roaming?

Mohammed
Userlevel 6
Badge +6
Hi @Eildon,

Are you having any issues with making calls/texts when abroad?

What network are you showing you're connected to?

One key thing I often advise users to try is to delete all of the current APN settings.
Then add fresh new ones with the ones outlined in the linked topic.
This can often reset you on the network and seems to work most of the time.

Have you tried manually connecting to a network?

Mohammed
Userlevel 1
We are in Spain, just outside Denia. But I had the same problem in Lisbon too.
Userlevel 1
Hi Mohammed, thank you for your help. For some reason (and I have no idea how) it has started working today. I followed the instructions to change apn settings for a second time and it is working, maybe I had a missing dot before, although I’m pretty sure I copied it exactly.
Again, thanks.
Eildon
Userlevel 6
Badge +6
Hey @Eildon,

I'm glad to hear this is now working!

Data Roaming issues are almost always down to incorrectly configured settings.

I hope you have a great time for however long is left on your holiday!

Mohammed

EDIT: I've moved a few of your posts made on another topic into this topic as they're both relating to the same issue. This avoids multiple conversations being started revolving the same issue.

I've also renamed the topic for clarity.
Ive recently returned from Tenerife and kept getting no service. Each time I turned phone on and off again had service for a while but lost it again but WiFi was ok. Followed suggested tips and noticed after taking out and reinserting sim card WiFi was stronger. I had needed to take phone cover off to do sim card and left it off after that and never lost service again all holiday.
Not sure if this will help anyone else

Reply