Question

ios 13.2.2 data not working

  • 9 November 2019
  • 5 replies
  • 49 views

Userlevel 1

Hi I have an iPhone XR on iOS 13.2.2 and my mobile data does not work. It wasn’t working before I updated to 13.2.2 either so I was hoping this would fix it. I have tried using the help pages but when I got to Settings → mobile data there is no where for me to check the APN settings. 


5 replies

Userlevel 3

Have you seen the words "No service" on your lock screen? If you have make sure the Sim is in properly and then restart your phone. If that doesn't work it could be a problem with the phone itself or the phone could be locked to a certain network.

 

Userlevel 1

It says I have 4g signal. I’m able to make and receive calls and sms message. Can’t do iMessage as that uses data. And my problem is with data. 

Userlevel 4
Badge +6

Hi @Rachybear 

Has data ever worked on your phone at all?

Are you able to test your SIM with any other phone?

 

Have you tried to reset the network settings yet?

Phil 

I have the same issue. Since yesterday before the 13.2.2 update, my mobile data was not working. 

It keeps showing the ‘searching’ symbol and eventually it just goes ‘no service’.

I was told that I needed to update my iphone in order to fix the issue. 

I’ve backed up and updated my phone through itunes 2 hours ago. The 13.2.2 update completed successfully, but the mobile data is still off and I don’t have an option to turn it on and off on the pull down menu.

I’ve turned my phone off and on again twice. 

This also happened on the last update. It means that at home I can connect to the Wi-Fi, but as soon as I leave the house I’ve got no internet connection and cannot make calls which is VERY annoying.

Is this a bug from the update or am I missing something?  

Thank you! 

Userlevel 6
Badge +6

Hello @Manasses,

 

It’s very odd that the option to turn on Mobile data has disappeared completely and could be linked to a bug. Have you tried speaking to Apple Support to see if they can provide some technical support on the issue as it’s sounding like it could be linked to a software issue rather than one with the network.

 

Happy to look into this further if you still believe it’s network linked, let us know.

 

Mohammed

 

 

Reply