Question

iPhone SE MMS Issue

  • 1 February 2019
  • 8 replies
  • 182 views

Hello all. I joined ID a week ago and ported my old mobile number across. Just discovered I can't send photos by text (MMS messages)
I have a £5 cap on my account so it shouldn't be the 30p charge
Ordinary texts work
Wifi calling is OFF
Under Settings > Mobile data > Carrier services - the number shown isn't mine, nor is the number i was first allocated
Under Settings > General > about > Carrier shows as iD 35.1, which I believe is correct
I can't get to the APN settings, which is pretty much the only other thing I can think of
Any thoughts please?

8 replies

Userlevel 6
Badge +6
Hey @JuliaB,

Try sending an MMS with iMessage turned OFF and let us know what happens.

Quite often, when APN settings aren't available, you may have the settings on:

Settings > General > Profiles

If there are any profiles showing, delete these.

If the cap isn't the issue, it's usually down to MMS settings on your phone.

Would it be possible to test the SIM in a non-iPhone handset to see if this allows the MMS to send?
You could also try sending an MMS to a different number to confirm this affects all numbers.

Mohammed
I feel sure it’s the MMS settings on the phone, too - if only I could get to them!

iMessage is OFF - no change
Nothing is listed under Profiles
I’ve tried a handful of different numbers and none of them are going through

I put the SIM in someone’s android handset and it started adding my google account to his phone, so we stopped that. Therefore I haven’t tested sending an MMS with my SIM in a non-iPhone.
Additionally when I put the SIM back in my own handset I got a text telling me about some configurations


And I still can’t send MMS messages

Any other thoughts please?
Userlevel 6
Badge +6
Hey @JuliaB,

You can try visiting the Get your Settings tool and see if your handset is compatible to have the settings sent to it directly.

Unfortunately, the issue regarding MMS messages would most likely be down to the settings on the device as opposed to a network issue.

Was this for a device purchased from us?

Mohammed
Hi @Mohammed

I've been down the "Get your settings" route and got the message that my device isn't enabled for this service.
This iPhone SE was supplied with my 24 month contract with ID... you'll understand that it's a bit irritating to be tied into a new 24 month contract with a handset that does less than my old one!
Do you have any other ideas please?
JuliaB
Userlevel 2
Badge +5
@JuliaBHi @JuliaB

If you could try sending it another handset or try a different SIM in your handset this will give us a little more information. The other thing that we suggest is to reset your network settings you can do this by doing the following.

Tap Settings > General > Reset> Reset Network Settings

Please let us know how you get on with this so that we can try to get to the bottom of it.

Kash
@Kash
i reset network settings as detailed above - no change, still can’t send MMS
i also tried this sim in my old iPhone and still can’t send MMS
My old Sim is deactivated so doesn’t work in this phone.
Any other ideas please?
Userlevel 6
Badge +6
Hello @JuliaB,

It would appear that there is not much more we can do to troubleshoot this and will need to raise this to our Technical Team to investigate further.

To allow us to do this, please can you email us on communitysupport@idmobile.co.uk

Please include your:
  • Full Name
  • Full address with postcode
  • Mobile Number
  • Date of birth
Please also include a link to this topic and your community username.

Mohammed
This seems to be an issue for ID and iPhone6 as I have it too.

Reply