messages not sending

  • 16 September 2020
  • 3 replies
  • 32 views

Hi, I changed network provider last week from 3 and requested a pac number. Filled the form in on iD mobile website to keep my old number and this was done successfully. I am able to make and receive calls, use data etc but my messages are not sending. When I try to message someone it says ‘message failed to send’ however the person I’m trying to send it to says they receive the message multiple times. 
I have used the iD mobile live chat several times and nothing seems to resolve the issue. The most recent agent told me to go to settings, phone, my number, and change the number - which I have done. Then to go to settings, iMessage, and update the number that I can receive messages to which I have done as well. I restarted my phone and tried to send a message and it still isn’t working. I also tried to go back onto the live chat which now isn’t working-  all it says is oops and takes me back onto iD mobile home page. 


3 replies

Hi, I changed network provider last week from 3 and requested a pac number. Filled the form in on iD mobile website to keep my old number and this was done successfully. I am able to make and receive calls, use data etc but my messages are not sending. When I try to message someone it says ‘message failed to send’ however the person I’m trying to send it to says they receive the message multiple times. 
I have used the iD mobile live chat several times and nothing seems to resolve the issue. The most recent agent told me to go to settings, phone, my number, and change the number - which I have done. Then to go to settings, iMessage, and update the number that I can receive messages to which I have done as well. I restarted my phone and tried to send a message and it still isn’t working. I also tried to go back onto the live chat which now isn’t working-  all it says is oops and takes me back onto iD mobile home page. 
 

 

Having the same problem!

Userlevel 7
Badge +9

Hello both,

Can you try the following:

 

1)    Turn off iMessage (Settings > Messages)
2)    Restart your phone (by pressing and holding the on/off button)
3)    Tap Settings > Phone > My Number and confirm that it is correct. 
4)    If it is not correct, please enter the correct number
5)    Turn iMessage back to On (Settings > Messages)
6)    Finally, go to Settings > Messages > Send & Receive and see if the correct number is displayed under “Start new conversations from:”. 

 

This is usually down to iMessage not updating the number correctly after a port and has been posted many times on the Community.

 

Let us know how you get on.

 

Mohammed

Reply