Solved

Wifi Calling Not Working

  • 17 October 2019
  • 30 replies
  • 4618 views

I have an iPhone SE with iOS 13.1.3. WiFi Calling has stopped working. I have tried all the suggestions ie turning WiFi Calling off and on, resetting the network, rebooting the phone. All to no avail. I know it’s not an issue related to our WiFi/internet service as my wife’s iPhone 5s on a BT contract can make WiFi calls perfectly well. Any suggestions please?

icon

Best answer by Phil 18 October 2019, 14:48

Hi @Cambridge Chris , @Zalgoark and @HM170B 

WiFi calling has been affected by recent network issues but should be working as expected now, if not, please restart your phone and if problems persist despite being connected to WiFi, please check on your phone, to turn off WiFi Calling, restart and reconnect to WiFi, then re enable WiFi calling.

 

Please reply here in this merged thread so we can address any ongoing problems, thanks.

-Phil 

View original

30 replies

Userlevel 1

This phone could connect to wifi calling until today. Recently it seemed to take a bit longer to switch to wifi calling, but today all I get is “No service” in the top left. Mobile calls still work. I have tried all the suggested options on this forum and others and have reset everything from resetting network settings on my phone through to rebooting and changing setting on my wireless router. The live chat on id mobile was hopeless as my comments were ignored and I just got boilerplate replies.

Things seemed to get worse not long after the recent ios update. I originally bought the phone sim free from John Lewis. The current ios version is 13.1.3. My broadband provider is Plusnet. I use a Netgear Nighthawk r7000p wireless router.

I’m hoping I get some joy from this forum, as it seems to me it is likely to be an issue at id mobile, since it seems unlikely that all this is happening out of the blue. I rely on wifi calling in order to make calls at home, due to the poor indoor reception and is therefore the main reason I chose this network.

Until yesterday, wifi calling was working on my iPhone 6s. Now, although the setting is active, it no longer works. The phone shows No Service rather than iD Wifi Calling. I have tried restarting the phone, with the setting off and on. I have restarted the router. Please help.

Userlevel 8
Badge +9

Hey @Cambridge Chris 

 

I am using Samsung Galaxy A40 which is compatible with iD Mobile WiFi Calling and it also worked for me until yesterday. I think this has something to do with outage that happened yesterday but this is just me thinking aloud. Three was fixing it on their side and confirmed that all services will be coming back shorty, I assume this includes WiFi Calling as well. I will wait couple of more days to see if WiFi Calling will be back. 

 

Kind Regards

Userlevel 4
Badge +6

Hi @Cambridge Chris , @Zalgoark and @HM170B 

WiFi calling has been affected by recent network issues but should be working as expected now, if not, please restart your phone and if problems persist despite being connected to WiFi, please check on your phone, to turn off WiFi Calling, restart and reconnect to WiFi, then re enable WiFi calling.

 

Please reply here in this merged thread so we can address any ongoing problems, thanks.

-Phil 

Userlevel 1

Thank you both for your replies. That’s interesting about a possible outage. This morning I put the phone in airplane mode and then reset Wi-Fi calling and reestablished Wi-Fi, which caused the phone to search for a signal and Wi-Fi calling kicked in. So maybe the problem is fixed. Will see how it behaves when I get back home.

much obliged!

Thanks for the info on network issues. I have tried your suggestions but so far still no WiFi Calling. 

Best regards Chris 

Userlevel 1

Hi there @Phil ,

 

I am also suffering the same problem as @Cambridge Chris, and I have tried all of your steps above.

 

In case it helps, I have a Sony Xperia XA2, running Android 9 (OS is customised UK not 3 UK running the R4B variation, not the R3B variation - see https://xpericheck.com/cda/1312-1464). It previously worked before the network problems started (so my phone is normally compatible with Wifi calling on ID mobile).

 

My 4g calling works fine. I have a SIM only contract that started May 2019.

 

Best wishes

 

Userlevel 1

Looks like I’m still not able to get Wi-Fi calling having checked again this evening. That’s also when the phone says no service. I haven’t therefore marked this issue as solved yet.

Userlevel 1

We have 3 phones with ID (2 android 1 iphone) and one on Three (IPhone), none of them have wifi calling active as of this morning and haven’t had since the problems started on Thursday.  We’ve done all the airplane mode, rebooting etc.

Looks like the problem may be at Three’s end but any chance we can get a bit more info about what’s going on and when it will be fixed ?  We have a rubbish standard signal here and wifi calling is important !

Userlevel 1

I have the same problem with wi fi calling. Started a couple of days ago when both our phones lost wi fi calling, then it came back again, then mine - but not my partner’s - went off again. Which is peculiar - we both have iPhone 5s’s. However, when I compare the information I can see in Settings>General>About>Carrier, IMS Status isn’t showing on my phone. I’ve tried all the variations on switching stuff on and off etc, have tried a network reset, all to no avail. Like other users on here, we have no mobile signal at home (Cumbria) and rely on wi fi calling. 

 

Having problems using wifi calling with a Samsung a20e. Can select the option in the phones settings but not able to receive the servive, and no ‘IDmobile wi-fi calling’ showing on lock screen. Phone is definitely on the compatabilty list.

New IDmobile sim-only contract set up early in October, and the problem seems to pre-date the recent Three outage. Have never been able to wi-fi calling with IDmobile.

Have tried a sim from another network in the phone and wi-fi calling worked fine.

Userlevel 1

Having problems using wifi calling with a Samsung a20e. Can select the option in the phones settings but not able to receive the servive, and no ‘IDmobile wi-fi calling’ showing on lock screen. Phone is definitely on the compatabilty list.

New IDmobile sim-only contract set up early in October, and the problem seems to pre-date the recent Three outage. Have never been able to wi-fi calling with IDmobile.

Have tried a sim from another network in the phone and wi-fi calling worked fine.

I joined in October too and have just left the network for one with decent indoor coverage since I can’t hang about waiting for this problem to be fixed.

Userlevel 1

Having problems using wifi calling with a Samsung a20e. Can select the option in the phones settings but not able to receive the servive, and no ‘IDmobile wi-fi calling’ showing on lock screen. Phone is definitely on the compatabilty list.

New IDmobile sim-only contract set up early in October, and the problem seems to pre-date the recent Three outage. Have never been able to wi-fi calling with IDmobile.

Have tried a sim from another network in the phone and wi-fi calling worked fine.

I joined in October too and have just left the network for one with decent indoor coverage since I can’t hang about waiting for this problem to be fixed.

I confused myself here, I joined Id in August and left in October. I was with Tesco, moved to Plusnet, then joined Id within the space of a few weeks, then joined Vodafone this week, which appears to have the indoor coverage I need. Coverage maps depending on provider seem to vary a lot in accuracy and the only way to find out is to suck it and see it seems. Wifi calling seemed to be away around the problem, but not in practice.

Userlevel 1

I’m brand new to wi-fi calling and not very techno savvy so I’m confused. My position is this: -

Having moved to  new house I found that my EE mobile signal was either none existant or very poor. EE were unable to help other than suggesting I use wi-fi calling. - I had never heard of this before but research suggested that to use it I needed a compaatible mobile and I had to be ‘on contract’ rather than be a ‘pay as you go’ user, - I did not qualify on either count.

I visited a Carphone Warehouse shop and was advised to purchase a new mobile which supported wi-fi calling on a cheap and basic contract. This I did. - I bought a Nokia 2.2 phone which was set up in the shop and wi-fi calling was activatedfor me. - I am now on the iD Mobile network via 3.

I have now had the new phone for 7 days and the wi-fi calling facility, this being my sole reason for  changing, does not seem to work.

It seems that the wi-fi calling icon will become visible when my phone signal is none existant but disappears again once the slightest network phone signal is detected. The trouble is that this very low ndetwork phone signal is insufficient to allow me to make or receive calls so wi-fi calling is needed but it is not available.

Any suggetions to help resolve the problem will be apreciated.

Thanks

Userlevel 1

So after doing some more reading and experimenting with my Nokia 2,2 mobile I have found a possible solution to my problem. It is clumsy and no doubt someone with technical knoiwledge could streamline it to make it more effective but this is it: -

The network signal in my homer us either very poor or none existant. Consequently, signal strength is continually phasing ‘in’ and dropping ‘out.’  When it is ‘in’ it is not strong enough to enable me to make or receive calls

Wi-Fi calling is enabled on  my phone but it does not work if it identifiess the slightest trace of a network signal. Consequently, beacuare tghe network signal is si erratic, it can never stabliise itself so it is fit for use.

To allow Wi-Fi calling to become stable it is therefore necessary to eliminate the network signal and I did this by activating ‘airplane mode.’ - On my phone doing this automatically switchess off the wifi signal so I then have to switch that back on manually. Having done so the network signal is disabled, Wi-Fi calling becomes stable and I can both make and receive calls via Wi-Fi calling without any problem. - Of course, when I leave home I have to remember to reinstate the network signal again.

This ‘workaround; has been working for me for the past 24 hours  and until something better comes along I shall continue to use it. - Hope these ccomments are helpful to others.

I assume this forum is monitored by a rep from iD Mobile so perhaps you can take these comments on board and think about simplyfying what I have done to make life easier for me and others. - Perhaps by developing a small app with a toggle switch so the various settings I have described can be changed more easily.

Userlevel 1

I, too, am having a major headache with Wi-Fi Calling: sometimes it is displayed as being available on the handset screen, sometimes not, and almost never when I want to make a call (which is potentially a serious problem for me because I live in a near-zero reception area).

Fortunately, though, I usually can make calls even when there is no signal and Wi-Fi Calling is not being displayed on the handset, but why this is I have no idea: I hazard a guess that either the background 4G service is a lot better than that of 2G or 3G and still functions even with no signal bars, or the call is still being routed through the router via the Wi-Fi Calling service even though the Wi-Fi Calling icon is not being displayed on the screen (data turned-off, so that eliminates the possibility of data usage from my service plan).

I have just tested the “airplane mode” solution, and can confirm that it appears to work (at least, I actually have the WFC icon on the handset again and it is staying there!). I also have a suspicion that Wi-Fi Calling depends on being able to connect to iDMobile; so zero reception would mean no WFC because the SIM-card cannot “call home” to verify the service plan provisioning. Additionally, this could explain why in good weather, for myself at least, WFC remains consistent and constantly available but fails catastrophically in those two requirements whenever the weather turns bad.

The only other issue I have with my setup, and which Sony have strangely told me to take-up with iDMobile, is that of the notorious Xperia 10 not connecting to hidden SSIDs (or only if the SSID is left open and then hidden once a connection has been made); except it has now become a case of it will not connect, or stay connected, to a hidden SSID network at all now ...so if anyone knows how to resolve this on an Xperia 10 with Android 10, please say (even if not on this particular thread).

Userlevel 5
Badge +7

Hi @ZaXDi3P6r89EoS,

 

Thanks for sharing your airplane mode fix success story, it will no doubt assist others.

 

Regarding the later problem you’ve mentioned, have you double checked to see that you’re currently on the latest Android update on your handset?

 

Will

Userlevel 1

My handset is Android 10, and the fix for hidden SSID is to tick the hidden network box in the advanced settings when adding a new network ...and, yes, it has got to be when you are adding a new network, becuase the hidden network option is no longer available once a network has actually been created.

As for Wi-Fi Calling, - I have given up on that, - the indicator for it is sometimes there, indicating that it might be working, but most of the time is not (regardless of whether airplane mode is on or not).

- ZaXDi3P6r89EoS

Userlevel 7
Badge +9

Hi @ZaXDi3P6r89EoS,

Thanks for the update, I’m glad you managed to find a fix for the hidden network issue. Wi-Fi calling availability is dictated by the Wi-Fi connection being used so at times, it may work intermittently.

Ryan

Hi,

Samsung Galaxy S9, Wifi Calling enabled, testing next to Wifi router with 36Mbps connection speed...but no Wifi calling. Worked fine with EE under the exact same conditions (same phone even) last week.

Any ideas?

Userlevel 4
Badge +6

Hi @OmariSnaymoe, if you purchased the phone elsewhere, we can’t guarantee that the device will be compatible with Wi-Fi Calling on our network, unfortunately. Is your phone running the most up-to-date system software?

 

Thank you,

Rory

Thanks for the reply Rory.

If that’s the case, it’s fairly annoying of ID not to let customers know that from the outset. Particularly as I would have thought that’s what most people will be doing in this situation; using an unlocked phone from a previous network with a SIM only ID deal. All ID’s website says is that there’s a list of compatible phones - mine’s one of them. I suppose the only answer’s to switch back to EE then...shame.

Userlevel 4
Badge +6

Hi @OmariSnaymoe, it’s the same with every network, I’m afraid; the Wi-Fi Calling feature is dependent on the firmware that the phone is flashed with at the time of distribution.

Is there a setting called ‘Wi-Fi preferred’ or something similar? Could you share a screenshot of what your Wi-Fi Calling menu looks like just so I can check for any potential errors?

 

Thank you,

Rory

I thought that might be the case Rory thanks. Though I still think this possibility should be made clear to customers from the outset. I have moved to ID, partially on the basis of WiFi calling capability, as I live in a remote area and rely on it to receive Mountain Rescue call-out notifications which are sent by text. Now I’m in a position where I can’t receive these notifications and need to go through the process of moving to a different network again.

I’m afraid there aren’t any WiFi calling settings - it’s a toggle on/off.

Thanks anyway.

Userlevel 4
Badge +6

Sorry to hear this, @OmariSnaymoe. We’ll certainly have this fed back to the Web Team to see if a line can be added to the page there. Thank you for your service in the Mountain Rescue, you all do a wonderful job!

 

Thank you,

Rory

Reply