Adult Content Filtering still active even though deactivated in iD app/dashboard

  • 26 January 2024
  • 7 replies

Userlevel 1

Trying to access certain websites, including innocuous ones like, is blocked for me despite →

Using Chrome to access such sites sends me to

So, how does one get around this?


Edit: 1) I should note, this is as of this afternoon; I’ve been with iD for three years and this is the first time I’ve had this problem. 2) This is while using 4G, not any other kind of networking like a home Wi-Fi network or whatnot.


Best answer by atcross 26 January 2024, 19:53

View original

7 replies

Userlevel 1

Problem solved: Restarting my phone resolved the issue (it’s always the simplest things, isn’t it?).

Userlevel 7
Badge +5

Hi @atcross 


Glad to hear a simple phone reboot helped here, please let us know if you need anything else.



Can anyone help me out please. Turned off the adult content in settings and also turned phone on and off and still can't access adult content. I've even looked in my browser settings and can't see anything in there either.

I'm getting the same issue

Userlevel 1

Same here, will try a reboot

Userlevel 1

Same here, will try a reboot

Hate it when everyone on forums says they'll get back and never do!! Anyway, a reboot actually worked for me too, weird!

Same here, tried reboot, switching off and on, customer services and nothing works.